1. rishabk97's Avatar
    Hello,

    Been experiencing this problem since the last two days. When I plugged in my phone to charge, it just wouldn't charge and the LED wouldn't glow. I tried connecting it to my laptop but the device wasn't recognized, so I restarted the device. And while it was getting booted, there was a high pitch noise for an instant when it displayed the Windows logo. On searching about it, I found this thread: https://forums.windowscentral.com/al...-speakers.html

    But unlike that thread, my speakers just work fine. The phone though was charging after the restart, but the catch is that it doesn't charge after few hours of starting up. Which means, when the battery gets low, I have to restart the phone to charge it. I have tried a soft reset.

    Any help is appreciated.

    Thank you.
    04-07-2018 11:30 PM
  2. editguy's Avatar
    Have you tried a different cable? I think it's a long shot, but might be worth a try. Otherwise, I think the only solution is a hard reset.
    04-18-2018 01:27 AM

Similar Threads

  1. my phone is frozen and shutting it down wont do anything. help?
    By behind the sea in forum Ask a Question
    Replies: 4
    Last Post: 04-07-2018, 09:00 PM
  2. my phone is frozen and shutting it down wont do anything. help?
    By behind the sea in forum Ask a Question
    Replies: 3
    Last Post: 04-06-2018, 10:03 PM
  3. Dropped my phone in water, seems fine if just for wifi
    By Erica Engelhard in forum Ask a Question
    Replies: 2
    Last Post: 04-06-2018, 09:31 AM
  4. Replacing the USB/charging port - Any experiences? It's hard?
    By DavidBS1989 in forum Nokia Lumia 930
    Replies: 0
    Last Post: 04-06-2018, 05:18 AM
  5. Replies: 0
    Last Post: 04-06-2018, 03:53 AM
LINK TO POST COPIED TO CLIPBOARD