1. podsnap's Avatar
    I'm experiencing a problem where the marketplace says there are updates (currently for Whatsapp, Bible, BBB: App-ocalypse) but when I click the Update All button in the marketplace on the phone, it jumps to the Downloads page correctly but nothing is listed.

    Nothing downloads.

    I can uninstall the apps and reinstall them fine but oddly the ones listed on the phone are the old versions!

    In Zune I can see the latest versions listed (but, of course, stupidly can't download them this way because they are 'already purchased') but on the phone they list the old version that I had installed!?

    Anyone else had this problem?

    Thanks.
    04-12-2012 05:53 AM
  2. michaelpartlow's Avatar
    Same problem here. I know updates are available, but they do not show in the marketplace. I guess uninstalling the app then downloading would work. Hopefully it's just a quick glitch that will work itself out.
    04-12-2012 09:45 AM
  3. podsnap's Avatar
    Odd thing is, when I uninstall the app and reinstall from the Marketplace, it installs the old version!

    How is that even possible?

    I thought a new version would override any old files in the Marketplace.
    04-12-2012 11:36 AM
  4. michaelpartlow's Avatar
    I uninstalled then installed with no problem. Everything works great.
    04-12-2012 01:15 PM
  5. markamericana's Avatar
    Did you ever get this sorted podsnap? I'm having the same problem - three of my apps, Whassap, Vevo and Twitter won't update. Even if I uninstall and then reinstall them, it just reinstalls the old versions for some reason. Having searched through google, it doesn't sound like this is a common problem but I'm at a loss at what to do now :(
    07-03-2012 06:07 AM
  6. fwaits's Avatar
    Have you guys tried rebooting the phones? Can't say I've seen this myself, maybe it's a regional market issue or some weird bug?
    07-03-2012 01:19 PM
  7. markamericana's Avatar
    I have thanks, I've tried even uninstalling, rebooting, leaving app uninstalled for a week and then reinstalling - exactly the same issue. Am wondering whether it's more to do with the phone (HTC Titan) than the os.
    07-10-2012 06:35 AM
LINK TO POST COPIED TO CLIPBOARD