1. landford's Avatar
    Have had a Lumia 900 for a couple of months, bought dozens of apps. The other day I go to buy and it says it can't. Says to check my accts I do, they seem fine. Still can't purchase. I add a new credit - same can't purchase. Any ideas??

    Help!

    Tom
    08-12-2012 11:46 AM
  2. Benzme's Avatar
    Have had a Lumia 900 for a couple of months, bought dozens of apps. The other day I go to buy and it says it can't. Says to check my accts I do, they seem fine. Still can't purchase. I add a new credit - same can't purchase. Any ideas??

    Help!

    Tom
    That happens to me a lot. I click "check account" and it comes up "buy" then I can purchase. Some just add the amount to my phone account, others I have to pay by credit card which I don't like because I'm sure there are other fees when such a small amount goes on the CC.
    08-13-2012 01:31 AM
  3. landford's Avatar
    Hey drphone thanks for the reply! - but where do you see "check amount"
    08-13-2012 06:55 AM
  4. mprebich's Avatar
    Any luck?

    I'm experiencing the same problem.

    Six weeks and no resolution from MS WP support.
    05-27-2013 08:26 PM
  5. mprebich's Avatar
    MS Windows Phone support finally admitted there IS an issue with some accounts not being able to purchase.

    My phone is in the US now and I still can't purchase.

    Three months and counting.



    Any luck?

    I'm experiencing the same problem.

    Six weeks and no resolution from MS WP support.
    07-11-2013 12:03 AM
  6. mprebich's Avatar
    Thought I should post the final outcome. WPsupport informed me that the problem was my MSA (Microsoft account) name. I was using an "illegal keyword that was being blocked by the system". Even though, there was no warning/error when I created the account, it worked over 9 months until i switched to WP8 on my L920, and only ended up blocked after 30 days active on WP8.

    Obviously, WP8 and the MSA system implemented new rules at some point.

    Anyway, the solution was to establish a new account and start over. Been up and running ever since.

    Thanks for all the suggestions.
    08-27-2013 12:31 AM
LINK TO POST COPIED TO CLIPBOARD