1. WhippedKream's Avatar
    Hey guys, I was wondering if this is just happening to me.

    I live in Montreal, Canada and I was using it the other day, as I have used it before, and it really messed up on me. It started doing some weird things such as telling me to turn right, when it meant turn left, and the route was different sometimes from what it told me. Or when I was on a highway it told me to keep right, but thankfully I read the signs and kept right then left, like it used to tell me :S. This is my first time using it as HERE drive, but before when it was Nokia Drive + beta on my 8X it was perfectly fine and didn't make these issues before. On my way back though it was not as bad, but it was still very strange. Even now I have it searching for my location and it says I'm two blocks away, when before it used to be accurate and tell me exactly where I was. Even yesterday it said I was near the highway which is 10 minutes from my house -___________-. I'm really confused, and is anybody having this issue as well? I love Nokia Drive and the offline maps functionality, but that other day really had me confused (as well as now).

    Thanks :)

    EDIT: Now it's again saying I'm right next to the highway! Help :( I tried uninstalling the apps, uninstalling the offline maps and everything to no avail... Help :/
    Last edited by WhippedKream; 04-21-2013 at 02:11 PM.
    04-21-2013 01:57 PM
  2. tiomi's Avatar
    Did you try restarting your phone? It may be the GPS that's off. It's happened to me once or twice that the app couldn't find my location, and restarting fixed the problem. 920 here.
    04-21-2013 02:54 PM
  3. WhippedKream's Avatar
    Did you try restarting your phone? It may be the GPS that's off. It's happened to me once or twice that the app couldn't find my location, and restarting fixed the problem. 920 here.
    To no avail my friend :'( like it's a block or two off but even my old optimus 7 doesn't have this issue. It's strange.
    04-21-2013 06:09 PM
  4. WhippedKream's Avatar
    Do you think that my region being US on my phone has an effect on this? Even though I'm in Canada?
    04-21-2013 06:19 PM
  5. Dratwister's Avatar
    Did you turn off the mobile data and try again? Sometimes I got wrong instructions too, but then I turn off mobile connection to use only GPS and it works just fine
    04-22-2013 03:15 AM
  6. WhippedKream's Avatar
    Did you turn off the mobile data and try again? Sometimes I got wrong instructions too, but then I turn off mobile connection to use only GPS and it works just fine
    The thing is I don't have data :S But I do leave wifi on (even without connection) cuz with my experience in the past I felt like it got stronger connection fast. We'll see next time I drive how it does on a route that I know well this time so I don't get lost. But I won't be driving for a bit haha that sucks.
    04-22-2013 11:45 AM

Similar Threads

  1. How do I load Nokia Drive from the Calendar?
    By l0cus in forum Windows Phone 8
    Replies: 19
    Last Post: 11-26-2014, 11:28 AM
  2. Here DRIVE Beta for other countries....??????
    By Vlado78 in forum Windows Phone 8
    Replies: 1
    Last Post: 04-01-2013, 10:49 AM
  3. Nokia Drive on the 8X?
    By kmann1994 in forum HTC 8X
    Replies: 34
    Last Post: 04-01-2013, 09:32 AM
  4. Nokia Drive+ sucks, and other mapping issues
    By TunaTank in forum Windows Phone 8
    Replies: 1
    Last Post: 12-26-2012, 11:29 AM
  5. Strange issues the last few days...
    By Bigsro in forum Nokia Lumia 900
    Replies: 0
    Last Post: 11-04-2012, 04:25 AM
LINK TO POST COPIED TO CLIPBOARD