1. croivo's Avatar
    I can't add my Nokia account to WP8, I use Lumia 520. When I go to settings > Nokia account, it just keep 'connecting', until I exit. Anybody have same problem?
    08-19-2013 07:39 AM
  2. WanderingTraveler's Avatar
    Switch the region of both your phone and Nokia account to the United States. That should solve the problem.
    08-19-2013 07:57 AM
  3. croivo's Avatar
    Changed to US, still loading forever.
    08-19-2013 08:41 AM
  4. WanderingTraveler's Avatar
    It worked for me, though. Perhaps the ROM of your phone blocks this.
    08-19-2013 05:01 PM
  5. Gaurav Goel's Avatar
    Hi, i had the same problem. The solution is simple, just update the nokia account on the update section of the windows store on your lumia. After updating the nokia account, simply open nokia account in the settings menu.
    10-18-2013 02:39 AM
  6. atif perwez's Avatar
    Problem is not solving
    11-26-2013 12:09 PM

Similar Threads

  1. 1020 ads seem to be working...
    By spaulagain in forum Nokia Lumia 1020
    Replies: 15
    Last Post: 08-22-2013, 12:19 PM
  2. Replies: 5
    Last Post: 08-20-2013, 02:55 PM
  3. Replies: 2
    Last Post: 08-19-2013, 07:52 AM
  4. Trying to understand how WP8 interprets ID3 tags.
    By pantsaregood in forum Windows Phone 8
    Replies: 4
    Last Post: 08-19-2013, 07:35 AM
  5. Nokia ProCamera Bass Filter Comparison..
    By antiochian2010 in forum Nokia Lumia 1020
    Replies: 1
    Last Post: 08-19-2013, 12:47 AM
LINK TO POST COPIED TO CLIPBOARD