The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Stefan Holder's Avatar
    I've noticed that the Telegram app drains my battery alot while in use. Using the battery saver app, it showed telegram causing a 53.9% drain on my battery in about an hour of use. Has anyone else experienced this? And can anyone tell me if a group chat will cause a messaging app to consume more power as opposed to a one to one chat? Check my screenshot below.




    Sent from my Samsung ATIV S using Tapatalk.
    Last edited by Stefan Holder; 11-21-2014 at 06:35 PM. Reason: inline photos not loading
    11-21-2014 06:07 PM
  2. Nabkawe5's Avatar
    Well as Microsoft doesn't separate HW from app consumptions I'd have to guess some kind of locational service within Telegram caused this, try turning off Location and check to see if consumption goes down, also remember that those % are not about current charge of battery they're a last 24h or a week consumption statistics they do not reflect that you consumed 53% of the last charge but of the entire 24h before charging and after. :)
    11-21-2014 06:57 PM
  3. Stefan Holder's Avatar
    Well as Microsoft doesn't separate HW from app consumptions I'd have to guess some kind of locational service within Telegram caused this, try turning off Location and check to see if consumption goes down, also remember that those % are not about current charge of battery they're a last 24h or a week consumption statistics they do not reflect that you consumed 53% of the last charge but of the entire 24h before charging and after. :)

    Location services within the app is always off.. I've even went as far as to turn off certain notifications and vibrate settings within the app..
    11-21-2014 07:02 PM
  4. Nabkawe5's Avatar
    By any chance do you use LTE, 3g? or Wifi?
    11-21-2014 07:19 PM
  5. Stefan Holder's Avatar
    By any chance do you use LTE, 3g? or Wifi?

    I use a combination of the latter two (3g or wifi)
    11-21-2014 09:35 PM
  6. Babbag3's Avatar
    I've had the same thing, on a L920 and L930. I'm sure it happened a couple of months ago after an upgrade. It is EATING battery like anything.

    NOT good.
    Stefan Holder likes this.
    12-04-2014 04:13 PM
  7. Stefan Holder's Avatar
    I've had the same thing, on a L920 and L930. I'm sure it happened a couple of months ago after an upgrade. It is EATING battery like anything.

    NOT good.


    I knew I wasn't crazy.. lmao
    12-05-2014 10:00 PM

Similar Threads

  1. Why am I having problems installing Movie Creator Beta?
    By p51mustang in forum Ask a Question
    Replies: 5
    Last Post: 11-28-2014, 05:53 AM
  2. PockIt - A Pocket Client : Beta
    By Piyush Raja in forum Developers Beta Testing
    Replies: 0
    Last Post: 11-19-2014, 06:34 AM
  3. Join the Windows Phone beta for comic reader Cover
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 11-18-2014, 09:08 PM
  4. 7 steps to make amazing videos with Movie Creator Beta
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-18-2014, 09:00 AM
  5. New contact manager app Onyu looking for Windows Phone beta testers
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-17-2014, 04:42 PM
LINK TO POST COPIED TO CLIPBOARD