1. WPCentral Question's Avatar
    Every time i start my SP3, my task manager is showing windows search filter taking up 30 percent of my cpu usage. I'm getting a little over three hours of battery life. I have about 50,000 items indexed. And I've seen indexing complete on several occasions. I've also tried to turn off indexing while on battery setting in the policies feature, but that isn't working. Any ideas?
    06-22-2014 03:10 AM
  2. gedzum's Avatar
    I was looking around and found this: http://www.ehow.com/about_6507773_mi...ter-host_.html

    While Search Filter Host is a legitimate and harmless Windows process, some users have reported that it can use almost all of a computer's resources.

    To fix this issue, Microsoft support engineers recommend to first rebuild the search index (link to procedure in Resources) to see if that solves the problem. If not, boot your computer in safe mode and see if the problem persists. Finally, perform a clean boot (link on how in Resources) to try to identify which application or driver might interfere with Search Filter Host. Another action you can take is to perform a full-system scan of your machine with a reputable antivirus application. Finally, if you are still experiencing this issue, try stopping the Windows Search process manually using Windows' Services Manager, rebooting your computer and restarting the process.
    Might be worth trying some of those steps. I hope it fixes your issue
    06-22-2014 04:36 AM

Similar Threads

  1. Have surface pro 3 may be returning it
    By msconfuse in forum Microsoft Surface Pro 3
    Replies: 22
    Last Post: 06-23-2014, 05:31 PM
  2. how to make hotspot on lumia 520
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 06-22-2014, 04:37 AM
  3. When will I get windows 8.1 update on lumia 520?
    By WPCentral Question in forum Ask a Question
    Replies: 3
    Last Post: 06-22-2014, 03:21 AM
  4. How many apps have you installed?
    By myst02 in forum Windows Phone 8
    Replies: 2
    Last Post: 06-22-2014, 03:04 AM
  5. L925 Win 8.1--how do I fix sound problems?
    By Cage Ata in forum Ask a Question
    Replies: 1
    Last Post: 06-22-2014, 02:00 AM
LINK TO POST COPIED TO CLIPBOARD