1. WPCentral Question's Avatar
    Hi, i'm running WP8.1 in a Nokia Lumia 625. I've been using it since day 1 but for two days now the phone won't connect to my WIFI (and also another WIFI close to home without password which I sometimes used when mine is down).

    When trying to connect it to my WIFI it asks for my password everytime (it was already saved)... I put the password and it takes me to a browser with the Windows Phone official page....but I can't see the navigation bar, and I only have two options "Skip" or "Cancel". Either way it won't connect after choosing one of the options. In the Notification Center on the WIFI icon says something like "Attention needed" (I'm guessing since my phone is in spanish).

    Weird thing is I went to a friends house and it connected automatically like it used to do with my two WIFI connections at home.

    Any thoughts?
    06-29-2014 11:21 PM
  2. Muessig's Avatar
    This is odd behaviour. Has anything changed with your home setup that could explain this?

    If not, try a soft reset by pressing the volume down + power button simultaneously for 10-15 seconds or until you feel a vibration. Let us know if this helps at all.
    06-30-2014 02:02 AM
  3. Omuald's Avatar
    Nothing changed in my setup (although the service has been crappy last week...).

    Weird thing is there's another connection (from somewhere else around my home) that I used when mine didn't work and it happens the same in both WIFI's.

    Soft reset didn't help.
    06-30-2014 02:10 AM
  4. Omuald's Avatar
    Just spent 2 hours with tech services of my internet provider and it is OK.

    Still tryng to connect and it connects as 'limited' and sends me to a browser still... please, any ther thoughts?
    06-30-2014 03:16 PM
  5. BiggishTuba558's Avatar
    I have the same problem with a netbook which needs the authentication via browser. I have to insert the password every time that my Lumia finds the netbook because it tells my intervention is required.
    09-05-2014 12:53 PM
  6. switch side method's Avatar
    Go to wifi and select "forget network" on your phone.

    Then turn off modem

    Turn off wifi on phone

    Turn modem on and wait 30 seconds

    Turn phone wifi on and it should work correctly
    09-05-2014 06:52 PM
  7. fmurphy1985's Avatar
    This worked for me. Thanks!
    01-23-2016 11:59 AM

Similar Threads

  1. Nokia Lumia 625 - Sound Issues - Connected to Battery Saver Mode?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 06-01-2015, 10:37 PM
  2. Wifi edit option
    By Pravin in forum Nokia Lumia 520
    Replies: 1
    Last Post: 06-29-2014, 09:00 PM
  3. Wifi edit option
    By Pravin in forum Ask a Question
    Replies: 1
    Last Post: 06-29-2014, 09:00 PM
  4. connecting to Wi-Fi network problems
    By AhmadSorour in forum Windows Phone 8.1 Preview for Developers
    Replies: 3
    Last Post: 06-28-2014, 05:59 PM
  5. Intermittent internet connectivity issue in my Lumia 630 Dual SIM Phone
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2014, 05:24 AM
LINK TO POST COPIED TO CLIPBOARD