1. Karthick_kaka's Avatar
    Whenever I use data through mobile network,the signal keeps on changing from H+ to H then comes to E even though I selected highest data speed as 3G.. I'm facing this problem for long time what can I do????
    08-02-2014 11:24 AM
  2. se7en20's Avatar
    Still depends on the signal. I have poor signal inside the house and I often got E but when I'm outside I usually got H+
    08-02-2014 11:48 AM
  3. Thisis_ugo's Avatar
    I too am facing this problem!!!! Any solution?
    08-02-2014 11:54 AM
  4. se7en20's Avatar
    Selecting 3g as highest speed doesn't mean you will always have 3g speed. It's the highest you can have depending on the signal.
    08-02-2014 12:01 PM
  5. prasath1234's Avatar
    Same problem am in ground floor inside my house I get only e whereas outside I get h➕ .









    Sent from my RM-826_im_india_201 using Tapatalk
    08-02-2014 12:02 PM
  6. xandros9's Avatar
    highest speed means just that. My 920 is set to have 4G as the highest speed, but when 4G/LTE is not available whether because of bad reception or it just not being available in the area, it falls back to H+, H, and E in rural areas.

    How do I fix it? Well, its not simple. Your phone isn't defective (unless it has abnormally worse reception than other phones), it's a shortcoming of your cellular network or something about your house reducing signals.
    Laura Knotek likes this.
    08-02-2014 12:05 PM
  7. lum5's Avatar
    No solution for this problem...bec the phone is working on auto mode like other handsets...in lumia we cannot set 2g or 3g permenantly..we can select 2g or 3g...but it will work in automode...
    xandros9 likes this.
    08-02-2014 01:02 PM
  8. prasath1234's Avatar
    Hope microsoft solve this issue in thier next update.
    Sent from my RM-826_im_india_201 using Tapatalk
    08-03-2014 03:21 AM
  9. xandros9's Avatar
    Hope microsoft solve this issue in thier next update.
    Sent from my RM-826_im_india_201 using Tapatalk
    No amount of software can compensate completely for a shortcoming of the hardware.
    Well, short of changing it to report H+ when it has only E (making it lie)

    Funny related story, one software update to the iPhone 4S changed the 3G indicator to 4G. What an upgrade! (Speeds remained the same) Although 3.5G has been advertised as 4G here in the US.
    08-04-2014 05:06 PM

Similar Threads

  1. signal problem 520
    By Abhishek Mullick in forum Ask a Question
    Replies: 3
    Last Post: 08-02-2014, 12:09 PM
  2. nokia lumia 820 display problem.
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-02-2014, 10:33 AM
  3. Problems with the Photos tile since Cyan install
    By someoneinwa in forum Windows Phone 8.1
    Replies: 0
    Last Post: 08-02-2014, 10:28 AM
  4. Nokia Lumia 630 SD Card problem
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-02-2014, 10:05 AM
  5. windows phone 8.1 internet connection
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-02-2014, 09:23 AM
LINK TO POST COPIED TO CLIPBOARD