1. prestsimp49's Avatar
    I have an at&t lumia 520 that I have been using on Straight Talk now for about 9 months with no issues. Last night I get the notification that an update is available, so being naive and assuming everything would be ok, I complied. Everything seems to go smoothly and be working fine until I go to send a picture this morning and it says "Can't Send". My 4g internet, wifi, sms, and calling all work fine, and my apn settings (tfdata..., etc) were not changed or erased during the update. I have scoured the internet with no solutions yet to be found. I use MMS frequently so i'm very concerned by this. Any solutions?
    Thanks in advance!
    08-08-2014 10:56 AM
  2. qqqqqzz's Avatar
    I had the same issue. Here is what I did to resolve the problem:

    1. Settings -> cellular+SIM -> Sim Settings
    2. Toggle Data Connection off and on
    3. Toggle Roaming off and on
    4. Sim Settings -> Added name to SIM Name (mine was blank)

    After doing these steps, my MMS once again started working. Not sure what steps or combination of are required but those are the steps I did that seemed to work for me.
    08-11-2014 01:56 PM
  3. maurierose's Avatar
    I have the same phone, same carrier, and tried the above solutions to no avail. I can't get or send MMS messages, and can't find anything on the internet or through search functions that works.

    Would love some help if anyone knows a solution.

    Thanks in advance!
    08-15-2014 04:19 PM
  4. maurierose's Avatar
    a few more posts before I can enter mine with settings as it has URLS in it.
    08-27-2014 02:47 PM
  5. maurierose's Avatar
    one more post to hit my 10 post minimum... instructions to follow...
    08-27-2014 02:47 PM
  6. maurierose's Avatar
    My apologies for the pointless posts - I could not enter URLs until I hit 10 posts. Here goes:

    Apparently there has been some sort of system update, as my phone started working and receiving/sending mms messages last night. These are the steps I did on my Nokia 520 (AT&T phone on Straight Talk service) the other day; Hubby's worked immediately after we repeated the steps on his phone (same phone/service/model).

    Here's what we did:
    Go to Settings, then CELLULAR+SIM.
    Toggle off Roaming.
    Toggle off Data Connection
    Delete all mms and internet profile settings by going to "edit internet APN" and "edit MMS APN" and pushing the delete/trash can icon at the bottom of the screen to delete each profile . Delete the SIM name (there is no "save" button, just backspace until all characters are gone, then hit home.)
    Do a soft reset by pushing and holding the power button and down volume button until the phone restarts itself.

    Go to Settings, then CELLULAR+SIM:
    Toggle Data Connection and Roaming back on.
    Enter phony settings as follows:
    Create New MMS APN:
    MMS APN: wap.tracfone
    MMS Proxy (WAP Gateway URL) 216.155.165.40
    WAP Gateway Port 8080
    MMSC (URL) Http://mms.tracfone.com
    MMSC Port: 8080
    Click the disc/save icon at the bottom of the screen.

    Create internet APN.
    APN: wap.tracfone
    Click the disc/save icon at the bottom of the screen.
    Do another soft reset by holding volume down and power buttons until phone restarts. Try sending MMS (pic message) to your own phone number. Wait until it comes back as failed in the same message folder. This step takes a while.... just be patient and wait.

    When you receive the "failed" message, go back to settings.
    Open "edit internet APN". Delete it again with the trash can icon at the bottom of the screen.
    Open "edit MMS APN". Delete it again with the trash can icon at the bottom of the screen

    Do yet another soft reset (hold power and volume down buttons until phone resets itself.)
    Go to CELLULAR+SIM
    Enter SIM name: Straighttalk (no spaces, no underscore)
    Add internet APN:
    APN: att.mvno
    (leave all other settings blank)
    Click the disc/save icon at the bottom of the screen.

    Add MMS APN:
    APN: att.mvno
    WAP gateway (URL): 66.209.11.33
    WAP gateway port: 80
    MMSC (URL): http://mmsc.cingular.com/
    MMSC port: 80
    (leave all other fields blank)
    Click the disc/save icon at the bottom of the screen.

    Do a soft reset by pressing and holding volume down + power buttons on phone until it restarts itself.

    Go back to your messaging folder - try sending another MMS (picture message) to yourself. This time it should work.

    Good luck!
    08-27-2014 02:48 PM
  7. rc2's Avatar
    ok so I also have a the same phone with straight talk.. and have no issues before this.. i did have to set apn settings so i could use the mms and internet when i first got phone. But now I just updated my phone 3 days ago, not aware of this issue beofrehand.. Only thing is I cannnot soft reboot since my power buttton is broken? So I just have to keep removing the battery to turn it off. And then plugging it in to outlet so it will turn on again? and I did this with all the steps you mentioned and it just wont work? is there anything else i can try other than getting another phone?

    thanks in advance,,
    08-27-2014 11:03 PM
  8. EngineerEagan's Avatar
    My Lumia 920 stopped receiving MMS yesterday after the Cyan update. I noticed the IPv4 was changed to IPv4v6 or something I changed it back and changed the att.mvno to tfdata, it works fine now.
    09-06-2014 04:30 PM

Similar Threads

  1. Cortana Alpha not appearing on Lumia 925 India
    By WPCentral Question in forum Ask a Question
    Replies: 12
    Last Post: 10-21-2014, 02:57 AM
  2. Charger simmilar to Nokia DC-17
    By adrian1338 in forum Windows Phone Accessories
    Replies: 1
    Last Post: 08-19-2014, 04:07 AM
  3. what will happen if i delete the preview for developers app
    By Tan LitKiat in forum Developers Corner
    Replies: 1
    Last Post: 08-08-2014, 11:11 AM
  4. Replies: 4
    Last Post: 08-08-2014, 10:16 AM
  5. Where is the Xbox Music update with GDR1?
    By Scott Franklin in forum Ask a Question
    Replies: 2
    Last Post: 08-08-2014, 10:08 AM
LINK TO POST COPIED TO CLIPBOARD