1. WPCentral Question's Avatar
    Had my Lumia 930 for a month now and are overall happy with the phone. However, the wifi is really slow. Loading pages takes 10-20 s and some times does not load at all, swiching wifi off and use 3g/4g the problem is gone. All other devices in the house do not have this problem on the same wifi connection. Any suggestions?
    Thanks
    Kim
    08-24-2014 04:52 AM
  2. Florin Micle's Avatar
    Hi Kim,

    Did you figure out anything related to your issue? I have a similar problem. I have two speed test apps, the one from Ookla reports the speeds I expect, the one from Microsoft takes forever to start the download (I just keep seeing the moving dots for 20-30 seconds) and when it finally starts the download the speed is a tenth of what I would expect. Facebook and FB messenger are awfully slow (pics take forever to load), but the App Store is mega-fast, 32 MB app downloads in 3 seconds. MSN News is also fast, streaming videos, no problem.

    Florin
    10-28-2014 08:55 PM
  3. Suicide Stacey's Avatar
    I believe the problem may be that the wifi router can only support so many devices before it starts to slow down. I recommend turning off all other wifi device but then just keep your running (disconnect and connect to wifi again) and see what the results are
    10-28-2014 09:49 PM
  4. Florin Micle's Avatar
    I believe something was wrong with the FB and Messenger app. Lately they have been working as expected, performance-wise. No changes on my WiFi configuration or phone settings, I just noticed one day that everything was "back to normal". I have a pretty decent router (not the default AT&T that gets installed when you sign up), so I didn't think it was a router issue.
    12-08-2014 02:43 PM
  5. A C7's Avatar
    I'm on the Telstra network and I find that it is incredibly slow. (No i'm not over my data limit and yes I should be getting 4G coverage.) Wi-Fi is also notably slower compared to peers at work who use other mobile devices
    04-13-2015 02:10 AM
  6. Dario Pendragon's Avatar
    The same with mine.
    Its nothing with the number of devices and even with the wifi. I think its something about the frequences of wifi router and wifi reception in the 930.
    Someone to help?
    Sorry my bad english...
    06-28-2015 02:17 PM
  7. Daniel Soriano1's Avatar
    Did someone figure this out? I'm having The same problem, my lumia930 takes forever to load pages, facebook and other apps, If I shutdown wifi and use 4G, everything goes really fast. I'm sure it's not my wifi connection, because I have other devices connected to it, and the loading speed is instantaneous.
    07-26-2015 06:33 AM

Similar Threads

  1. Wi-Fi and copy text on IE
    By DimitrisGrc in forum Windows Phone 8.1
    Replies: 2
    Last Post: 12-12-2014, 10:27 PM
  2. How do I fix unresponsive touch in lumia 1320?
    By Sayantan Mukherjee1 in forum Ask a Question
    Replies: 8
    Last Post: 10-29-2014, 12:54 AM
  3. Can't open files in OneDrive on my Nokia Lumia 1520.
    By robinperrett in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 08-25-2014, 08:19 PM
  4. Windows Lumia 925 8.1 OS
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-24-2014, 08:26 AM
  5. Deal of the Day: Amzer Pudding TPU Case for Nokia Lumia 1320
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-24-2014, 04:11 AM
LINK TO POST COPIED TO CLIPBOARD