1. dasshubham762's Avatar
    I'm using Nokia Lumia 520 about 1yrs. My phone is running Windows Phone 8.1 GDR1. I've updated the last 34 mb update. I'm getting home screen lagging issues. When I'm going back (or hitting start button) to home screen from any app(Nokia Camera, UC Browser etc.) home screen animation lagging. Some times tile icons got blanked. I've not pointed Cortana live tile in my home screen but still problem happens. I've also tried a hard reset but not get any changes. Do anyone facing the same issue with their Lumia???
    Please reply for solution and who facing this problem.
    08-31-2014 04:09 AM
  2. ivdza's Avatar
    I have the same problem with my 520..even hard reset didnt solve the problem... We will see. I think there is no solution for now and we have to live with it....maybe 512mb is a problem.. Or processor :(
    Last edited by ivdza; 08-31-2014 at 04:58 AM.
    dasshubham762 likes this.
    08-31-2014 04:40 AM
  3. dasshubham762's Avatar
    Which apps makes this problems in your case? In my case when I'm closing Nokia camera, camera 360 , etc apps then lag happened. Any other apps running smoothly. Have you faced this problem in WP 8??
    08-31-2014 07:02 AM
  4. ivdza's Avatar
    No,i i am facing it after last update like you. After almost all apps...
    08-31-2014 08:36 AM
  5. p4l0m0's Avatar
    I have the same problem...
    08-31-2014 08:50 AM
  6. Rajat Malhotra's Avatar
    Three reasons:
    1. Ur running a developer preview
    2. Old firmware
    3. The device is almost 2 years old. How much can u still expect from it?
    The best thing is we are still getting these updates.... Imagine if u had an entry level android phone!
    This problem is not just with 520....even 920/1020 users report the same issue.
    08-31-2014 08:59 AM
  7. Sandeep Randhawa's Avatar
    I have 1520 running WP 8.1 GDR1 with cyan. It happens with my phone too. Don't yet have any solution to this problem.
    08-31-2014 09:10 AM
  8. Ashwin J Pillai's Avatar
    Remove the background image.. It reduced the lag a bit in my 520...
    08-31-2014 09:11 AM
  9. ivdza's Avatar
    Three reasons:
    1. Ur running a developer preview
    2. Old firmware
    3. The device is almost 2 years old. How much can u still expect from it?
    The best thing is we are still getting these updates.... Imagine if u had an entry level android phone!
    This problem is not just with 520....even 920/1020 users report the same issue.
    Everything you said i know allready,i am not complaining..my next phone is 530. Because even that i have i dont want to spend fortune on a device :) i really dont need high end phone....
    I need a phone to talk,send txt's (viber,whatsapp) time to time for light surfing and thats it... :)
    08-31-2014 09:12 AM
  10. ivdza's Avatar
    After last update my phone stops lagging when i return to home screen when exiting apps :) even phone seem to run smoother. I didnt soft or hard reset my phone after this update....last soft reset was 3 months ago :D
    09-25-2014 05:40 AM

Similar Threads

  1. Outlook 2013 vs Windows 8.1 Mail App: what's better?
    By skstrials in forum Microsoft Office
    Replies: 10
    Last Post: 10-25-2015, 10:32 AM
  2. Lumia 630 dual proxy authentication bug during wifi
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 11-30-2014, 11:53 AM
  3. MMS not working on Red Pocket
    By hasasimo in forum Carrier Discussion Lounge
    Replies: 1
    Last Post: 10-14-2014, 08:32 PM
  4. Agenda view missing from Calendar?
    By gomezz in forum Applications
    Replies: 7
    Last Post: 09-03-2014, 03:38 PM
  5. Official Xbox media app thread
    By Bobvfr in forum The Xbox Lounge
    Replies: 0
    Last Post: 08-31-2014, 03:43 AM
LINK TO POST COPIED TO CLIPBOARD