1. WPCentral Question's Avatar
    I have a Lumia 620 using the latest dev preview, and the twitter application fails to give notifications (the toast thingy)

    Any ways to fix this? Or is there a better twitter application? I'm using the official one.
    08-31-2014 03:57 AM
  2. Nickkk101's Avatar
    I have a Lumia 620 using the latest dev preview, and the twitter application fails to give notifications (the toast thingy)

    Any ways to fix this? Or is there a better twitter application? I'm using the official one.
    Sadly, I'm up against the same issue as are some others. Doesn't appear to be a solution as of today. Using a 920 on 8.1 Update1 DP. Can't prompt it to get a notification at all.
    09-08-2014 01:31 PM
  3. wpfanboy17's Avatar
    Apart from allowing notifications for twitter in notification center, you also need to turn on notifications in the twitter app for the entities you follow.

    But doing so would cause duplicate notifications which is a current bug in twitter app.
    09-08-2014 01:54 PM
  4. Nickkk101's Avatar
    Apart from allowing notifications for twitter in notification center, you also need to turn on notifications in the twitter app for the entities you follow.

    But doing so would cause duplicate notifications which is a current bug in twitter app.
    How are you allowing notifications in notification centre...? To my knowledge the app doesn't appear until a notification is activated. The in app settings are all toggled to allow all notifications possible. My issue is that I haven't received any notification in action centre despite several tweets/mentions etc taking place. Furthermore, there is no toast, tile count, banner or sound. The phone remains silent. All other apps seem to be operating as expected..
    09-08-2014 02:41 PM
  5. wpfanboy17's Avatar
    How are you allowing notifications in notification centre...? To my knowledge the app doesn't appear until a notification is activated. The in app settings are all toggled to allow all notifications possible. My issue is that I haven't received any notification in action centre despite several tweets/mentions etc taking place. Furthermore, there is no toast, tile count, banner or sound. The phone remains silent. All other apps seem to be operating as expected..
    ok, here are the settings...

    1) Phone Settings->notifications+actions->Hit 'Twitter' app-> 'Show notification banners' ON and 'show in action center' ON
    2) Open twitter app..
    - select the entity, hit ... and then hit 'turn on notifications'.
    - Settings->Select your twitter account->Turn on notifications
    09-08-2014 03:09 PM
  6. Nickkk101's Avatar
    ok, here are the settings...

    1) Phone Settings->notifications+actions->Hit 'Twitter' app-> 'Show notification banners' ON and 'show in action center' ON
    2) Open twitter app..
    - select the entity, hit ... and then hit 'turn on notifications'.
    - Settings->Select your twitter account->Turn on notifications
    Ok.. but my problem is still as I mentioned above: Twitter is NOT appearing in the action centre list-therefore I cannot select "Show notification banners' ON and 'show in action center' ON" as is the case when an app does appear in action centre.

    The apps within notification centre ONLY appear when you receive a notification for the first time, and if you're not getting notifications like me, then that app never appears in the list. This is the issue. All in app settings within twitter are set to enable notifications. Reinstalling app doesn't work.
    09-08-2014 04:11 PM
  7. ShaneRay's Avatar
    There's something really funky going on with Notifications (for many apps).

    I was running WP 8.1 Update 1 (without Cyan) all was well. Rolled everything back to 8.0 to get cyan. Afterwards all notifications have stopped except for phone, outlook, messaging, and store (which, also, are the ONLY apps that will appear in Notifications+actions regardless). So, on 8.1 update 1, no notifications. Just did a hard reset earlier so am back on plain 8.1, and still no notifications.

    Not hijacking thread(s), but I've seen more than one today with this issue, so I'm just adding my information...I haven't got a clue what the issue is.

    EDIT: just to add...this is NOT a problem with any settings. Something else is going on.
    09-08-2014 04:59 PM
  8. Nickkk101's Avatar
    There's something really funky going on with Notifications (for many apps).

    I was running WP 8.1 Update 1 (without Cyan) all was well. Rolled everything back to 8.0 to get cyan. Afterwards all notifications have stopped except for phone, outlook, messaging, and store (which, also, are the ONLY apps that will appear in Notifications+actions regardless). So, on 8.1 update 1, no notifications. Just did a hard reset earlier so am back on plain 8.1, and still no notifications.

    Not hijacking thread(s), but I've seen more than one today with this issue, so I'm just adding my information...I haven't got a clue what the issue is.

    EDIT: just to add...this is NOT a problem with any settings. Something else is going on.
    Interesting. Similarly like you, I had also decided to roll back to get Cyan and Update 1 (I couldn't get Update 1/ cyan due to on going broken Dev Preview issue) which worked successfully on my 920. All of my apps are seemingly working fine regarding notifications/action centre Fb, WhatsApp, Outlook, Store etc.. but I started to realise I hadn't heard twitter in a while after knowing of mentions on the desktop and low and behold... something is up with it! I wonder if it is related to Update 1 via the dev preview, but your roll back suggests otherwise.. damn annoying!!
    09-08-2014 05:23 PM
  9. ShaneRay's Avatar
    Interesting. Similarly like you, I had also decided to roll back to get Cyan and Update 1 (I couldn't get Update 1/ cyan due to on going broken Dev Preview issue) which worked successfully on my 920. All of my apps are seemingly working fine regarding notifications/action centre Fb, WhatsApp, Outlook, Store etc.. but I started to realise I hadn't heard twitter in a while after knowing of mentions on the desktop and low and behold... something is up with it! I wonder if it is related to Update 1 via the dev preview, but your roll back suggests otherwise.. damn annoying!!
    I'm actually starting to wonder if it's not my particular ROM for some reason. I had to flash the ROM via Nokia Care Suite due to an unrelated issue. I see that my carrier is installing crap it never used to (Zinio?? what the hell is that?)...wonder if they didn't mess something up. I can't think of another good reason...
    09-08-2014 05:41 PM
  10. ShaneRay's Avatar
    Sorry for the posts, but I need to correct my first post a few above this one.

    It seems I am on Update 1 after all. For some reason, the hard reset I did earlier didn't wipe out the developer preview. Now I'm really scratching my head.
    Nickkk101 likes this.
    09-08-2014 05:58 PM
  11. Nickkk101's Avatar
    I'm actually starting to wonder if it's not my particular ROM for some reason. I had to flash the ROM via Nokia Care Suite due to an unrelated issue. I see that my carrier is installing crap it never used to (Zinio?? what the hell is that?)...wonder if they didn't mess something up. I can't think of another good reason...
    In my case, with all other apps/notifications working as they should and only Twitter not playing ball...I'm thinking its Twitter's back end. Its happened before. Google famously could bork YouTube on WP almost weekly with changes. Factor in the Dev Preview then there may well be a clash of some sort.

    As an aside, until I blew away the OS and got back to 8.1+Up1 I was using Twitter Beta, and Tweetium. The reinstall of the apps meant I lost Twitter Beta as it has since been de listed from the store. I knew for a fact that Twitter Beta's notifications were reliable as I got at least one (usually) double notifications in the Action Centre. It was stable and reliable for the notifications but I much prefer using Tweetium. Now, I just have the 'broken' public Twitter app and Tweetium. Out of frustration, I just an hour ago decided to upgrade Tweetium to Pro for a few pounds a year as I use it on the desktop also (RT) and whadda ya know... instant notifications first time. Notification Centre and all. Not a solution as such but I can recommend Tweetium. Even free its great although push notifications are limited to a pro version sadly. I'm glad to pay though, the app is excellent.
    ShaneRay likes this.
    09-08-2014 07:04 PM
  12. docles2002's Avatar
    Guys let us bombard the uservoice to let msft know of this issue and trigger an investigation. I too am having a no notification issue with regards to twitter
    Nickkk101 likes this.
    09-09-2014 09:34 PM
  13. ShaneRay's Avatar
    Sorry for the posts, but I need to correct my first post a few above this one.

    It seems I am on Update 1 after all. For some reason, the hard reset I did earlier didn't wipe out the developer preview. Now I'm really scratching my head.
    I'm only replying here in case a "newbie" comes along and gets the wrong idea...

    I don't know what I was smoking that day as I have no idea why I thought a hard reset would wipe out the developer preview (It, of course, doesn't and I knew that). Man, just one of those days...

    Anyway, my phone and notifications are now back to normal.....except for Twitter (official app).
    Nickkk101 likes this.
    09-10-2014 04:34 PM
  14. sirgrant618's Avatar
    I'm having twitter notification issues, as well as Facebook and facebook messenger, skype, and any other app that requires push notifications. none of them work on my phone or on my surface.
    09-10-2014 10:16 PM
  15. ShaneRay's Avatar
    There's a bunch of different thread on this, but I'll post here since I kinda post-bombed this thread anyway...lol.

    Anyway, just last night for whatever reason, the notifications started working suddenly--and correctly--again. Very strange as nothing was updated on the phone. Wonder if Twitter did something on their backend...
    09-24-2014 06:02 PM
  16. fwaits's Avatar
    I just got done updating my Lumia 920 (AT&T) and also went in to the Twitter settings and toggled the individual tweet setting off, exited, then went back in and turned it back on, exited again and within 10 minutes I got twitter notifications and they have been working since. Maybe the new update corrected some specific bug that the Twitter app was affected by on some devices... Not sure.
    09-24-2014 09:34 PM

Similar Threads

  1. Not getting Skype notifications
    By I3unny in forum Windows Phone 8.1
    Replies: 2
    Last Post: 09-02-2014, 09:50 PM
  2. Skype Notifications
    By Unregistered in forum Ask a Question
    Replies: 1
    Last Post: 08-31-2014, 02:14 AM
  3. Grab Twitter and Instagram stat tracker UnfollowSpy for free during the next three days
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-29-2014, 09:00 PM
  4. why no notification light in wp
    By WPCentral Question in forum Ask a Question
    Replies: 8
    Last Post: 08-29-2014, 07:52 PM
  5. No notifications
    By Brodan Turner in forum Ask a Question
    Replies: 6
    Last Post: 08-29-2014, 08:12 AM
LINK TO POST COPIED TO CLIPBOARD