1. technovm's Avatar
    I have updated Lumia 525 to cyan firmware version 3058.50000.1425.0002, here in India, but after update, battery drains very quickly and the back of the phone just above the camera gets hot even when the phone is idle. Whatsapp and Skype are running in background, and wifi is enabled, cellular data disabled. If the battery at 10 pm at night is 50%, with wifi disabled, by 6 am in the morning the battery is zero and phone turns off. I have turned on battery saver, selected when battery is low. I have also switched the cellular network from 3G to 2G.

    When 525 had black firmware, the battery used to last for 1.5 to 2 days, with whatsapp, skype in background, wifi turned on for the whole day. Also there were no issues with heating. But after cyan update I have to charge the phone 2 to 3 times in a day.

    I have tried hard reset. At night about 10 PM, battery was 47%, with wifi, cellular network off, and the only background task whatsapp and Skype, in the morning at about 7 AM the battery was down to 0% and phone switched off. I have also tried to deleting google mail, and restarting phone and creating new google account, sync 30 min and contacts etc sync is manual. Advertising ID is off, auto backup and sync off.

    I have also tried to put the phone in flight mode, at night when the battery was 50%, in the morning after was 19%, the drain is less but still there.

    Battery drain is approximately 10 to 11% per hour in flight mode and idle condition, but previously with black firmware had 1 to 2 % per hour.

    Please advice.

    Can this be a problem with the phone or others are having this problem on L525
    Last edited by technovm; 09-04-2014 at 12:28 PM.
    09-04-2014 09:41 AM
  2. Ashish Gupta888's Avatar
    Battery inside a 525 device drains too fast and heating issue is pretty common (Most of the Lumia devices face heating issues).
    For me, and for most of 525 users, it never lasted for 1.5-2 days (Neither in WP8 days nor in WP8.1.1 days :-))
    When it was running Black firmware with WP8, it used to be the same. I was hoping if Cyan can do some magic, but hard luck!
    09-04-2014 10:22 AM
  3. Rahul Kamble1's Avatar
    Mine having the same problem. But not immediately after the cyan update. And hard resetting doesn't help. Frustrated, battery life used to be awesome .

    Posted via the Windows Phone Central App for Android
    09-16-2014 09:19 PM

Similar Threads

  1. Replies: 19
    Last Post: 09-08-2014, 08:35 PM
  2. Replies: 4
    Last Post: 09-05-2014, 02:51 PM
  3. DP 8.1 & Cyan
    By Roni96 in forum Windows Phone 8.1
    Replies: 3
    Last Post: 09-04-2014, 10:19 AM
  4. Hands-on time with the affordable flagship Lumia 830 and its enhanced PureView tech
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-04-2014, 09:11 AM
  5. I cant send or recieve emoticons on my windows lumia 520
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 09-04-2014, 08:52 AM
LINK TO POST COPIED TO CLIPBOARD