1. WPCentral Question's Avatar
    After my Lumia 920 was updated to Cyan I experience problems with the touch panel. All of a sudden, the phone goes crazy clicking random things by it self and/or stop responding to touch. If I turn the screen lock on and of, the problem disappears but recurs after some random time.

    So far I have only experienced the problem when I use the phone while charging.

    Has anyone experienced the same problem? Are there any solutions?
    09-09-2014 01:55 AM
  2. N_LaRUE's Avatar
    Do you have a protective film on and do you have your touch setting turned up?
    09-09-2014 02:10 AM
  3. Mia Ingmarsdotter's Avatar
    No, no protective film or such.

    My touch settings are
    Touch sensitivity: high

    Is that what you mean by "turned up"? I need it to be set to "high" when I use my riding gloves. Besides, this setting works just fine most of the time (probably only as long as I don't plug in the charging cable)? I'll try to change the touch settings when I'm charging the phone to find out if this is the problem. I COULD pull the charging cord when I want to use the phone. But it sucks when I use Here Drive+ in the car - that app drains the battery as fast as a dog who thinks he's about to miss dinner )
    09-09-2014 02:45 AM
  4. N_LaRUE's Avatar
    Have you tried a soft reset? This may help.

    Hold volume down and the power button until the phone vibrates and the phone will restart. You may need to reset time and date.

    If this doesn't work the other option is a hard reset but that will wipe your phone clean. If you play games or have certain apps that save data to the phone this could be an issue for you but it would probably fix this.
    09-09-2014 02:53 AM
  5. hacer619's Avatar
    This happens to me. It is not related to cyan, any phone will do this if you connect a weak charger to it, specially those fake ones. Try connecting a charger with >1200mA rating.
    Mia Ingmarsdotter likes this.
    09-09-2014 03:23 AM
  6. Mia Ingmarsdotter's Avatar
    I found the problem! Just as Hacer619 said, there was something wrong with the charger. It is an original Nokia phone charger, so it's probably broken in some way. I found out when I switched charger with my boyfriend - actually to rule out the possibility of charger problems. My boyfriends phone (Lumia 1520) seems to have no problems with it however...

    Updated phone, updated charger = happy Mia
    hacer619 likes this.
    09-15-2014 02:24 AM

Similar Threads

  1. Group Thread Messaging Issue After Updating to 8.1
    By albertico in forum Windows Phone 8.1
    Replies: 8
    Last Post: 10-18-2014, 09:13 PM
  2. My Wi-Fi seems to have stopped working
    By Doctor_Who in forum Nokia Lumia 928
    Replies: 6
    Last Post: 09-12-2014, 07:51 PM
  3. Mailbox update issue
    By Ritesh Bhatia in forum Windows Phone 8.1
    Replies: 3
    Last Post: 09-10-2014, 06:31 AM
  4. ICE - In case of emergency phonr number
    By Wingerr in forum Nokia Lumia 928
    Replies: 6
    Last Post: 09-09-2014, 07:28 AM
  5. How to connect Lumia 520 to pc
    By deepvora in forum Ask a Question
    Replies: 1
    Last Post: 09-09-2014, 03:08 AM
LINK TO POST COPIED TO CLIPBOARD