1. WPCentral Question's Avatar
    Since this week's update of Windows 8.1 on my Surface Pro (version 1), the Marvell AVASTAR Wireless Composite Device driver (version 14.69.17064.93 - up to date, it seems) is not working, and I am shut off the internet.

    I had the same issue twice, in two earlier Windows updates this summer - but back then, I could get back online by picking the "Roll Back Driver" option under device management, and roll back to some earlier MS driver. THIS IS NOT POSSIBLE NOW as apparently since the last update, all earlier driver versions were eliminated from my Surface.

    So, what other solution might there be?
    09-18-2014 04:26 PM
  2. Laura Knotek's Avatar
    Have you contacted Microsoft support and asked them? Contact Microsoft Answer Desk for Surface
    09-19-2014 12:15 AM

Similar Threads

  1. Call Blocking - Not working for Unknown Calls
    By Talderon in forum Windows Phone 8.1
    Replies: 4
    Last Post: 12-22-2014, 12:21 PM
  2. No Data use until WiFi Detected ?
    By ReprobusR in forum Windows Phone 8.1
    Replies: 2
    Last Post: 09-19-2014, 10:27 AM
  3. wifi connects but no longer works
    By kmmcdonald in forum Nokia Lumia 925
    Replies: 1
    Last Post: 09-18-2014, 06:12 PM
  4. 1020 occasional no alarm vibrate
    By BrayMatter in forum Nokia Lumia 1020
    Replies: 0
    Last Post: 09-18-2014, 01:54 PM
  5. Stuff doesn't open
    By WPCentral Question in forum Ask a Question
    Replies: 3
    Last Post: 09-18-2014, 03:06 AM
LINK TO POST COPIED TO CLIPBOARD