There should be "never" option in "require password a after" lock screen setting.

Printable View