1. WPCentral Question's Avatar
    It's a Nokia Lumia 1520, not even close to a year old. It was working fine till the soft buttons (the back, windows and search buttons at the bottom) just froze up. They don't let me click or anything. I've restarted my device like a zillion times. It's also updated with the last update that released.

    Please help me on what I must do.

    Thanks
    10-02-2014 09:41 PM
  2. k0de's Avatar
    Did you try soft reset? (Hold the down volume and power button for 15 seconds till phone vibrates).
    10-02-2014 09:45 PM
  3. DianaMS's Avatar
    I did. It hasn't fixed the problem either. I must add that the three buttons light up but not work. Please help.
    10-03-2014 02:06 AM
  4. k0de's Avatar
    I did. It hasn't fixed the problem either. I must add that the three buttons light up but not work. Please help.
    Try hard reset but make sure you backup your important data. I've did before and lost nothing. Just pick back up from existing phone when starting over.

    ~Enjoy,
    10-03-2014 07:30 PM
  5. ShinraCorp's Avatar
    And if the hard reset doesn't work then the connector probably isn't well connected.
    10-03-2014 09:09 PM

Similar Threads

  1. Edited: The Road to Threshold - A history of Windows Phone
    By Ebuka Allison in forum Microsoft News & Rumors
    Replies: 13
    Last Post: 10-10-2014, 10:10 AM
  2. List of things that are heavily unlikely to happen
    By someone2639 in forum The "Off Topic" Lounge
    Replies: 20
    Last Post: 10-09-2014, 06:01 PM
  3. Problem with Nokia Lumia 2520
    By CodeGunnerDevelopment in forum Nokia Lumia 2520
    Replies: 3
    Last Post: 10-06-2014, 09:10 PM
  4. How do I upload videos?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 10-02-2014, 09:34 PM
  5. Replies: 0
    Last Post: 10-02-2014, 09:07 PM
LINK TO POST COPIED TO CLIPBOARD