1. AhmadSorour's Avatar
    Hello,i'm facing a problem that the glance doesn't open..it says rrstart your phone to complete the installation of tge latest updates...when i press restart tge phone restarts and i open glance tgen gives the same msg again...i tried it alot..i did a soft rest ( i think it's the same as restarting but i just tried) and nothing happened
    Any ideas?
    10-08-2014 09:09 AM
  2. pankaj981's Avatar
    Something might have been corrupted. I would reinstall glance and weather again if I were you. Change the date to something like 2114, click on glance to uninstall it. Revert the date back to 2014, install weather, restart phone and reinstall glance first, check to see if it works (perform reboot if it asks) and then reinstall weather
    10-08-2014 09:16 AM
  3. AhmadSorour's Avatar
    Something might have been corrupted. I would reinstall glance and weather again if I were you. Change the date to something like 2114, click on glance to uninstall it. Revert the date back to 2014, install weather, restart phone and reinstall glance first, check to see if it works (perform reboot if it asks) and then reinstall weather
    Ok thanks! I'll try it right away!
    10-08-2014 10:10 AM
  4. AhmadSorour's Avatar
    Ok thanks! I'll try it right away!
    Mmmmm...i followed every single step..when i open glance back again after reinstalling and changing date to Now...it is still asking for Restart...i pressed restart back again and when it's i opened the glance..and yes..it asks for restarting agaim Any other ideas? Thanks for trying to help :) !
    10-08-2014 10:23 AM
  5. pankaj981's Avatar
    Well in that case do you mind posting your OS version? Also download an app called SysApp Pusher and update all Lumia system apps using it. Give it a shot, I'm not sure whether it would help though
    10-08-2014 04:20 PM
  6. AhmadSorour's Avatar
    Well in that case do you mind posting your OS version? Also download an app called SysApp Pusher and update all Lumia system apps using it. Give it a shot, I'm not sure whether it would help though
    It didn't work also..but I tried a hard reset an here it works again... I'm just sad that fixing a problem requires a hard reset !!!
    Thanks for tying to help ! :)
    10-09-2014 06:19 AM

Similar Threads

  1. [L520] Getting the W10 update?
    By WPCentral Question in forum Ask a Question
    Replies: 4
    Last Post: 10-08-2014, 12:07 PM
  2. Lumia 720 and Cyan update
    By FAHMI BASSEM in forum Nokia Lumia 720
    Replies: 3
    Last Post: 10-08-2014, 09:11 AM
  3. New book looks at Stephen Elop's reign as Nokia and calls him 'one of the world's worst' CEOs
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 3
    Last Post: 10-08-2014, 08:58 AM
  4. Lumia 720 Cyan Update Experiences?
    By frenzyvanrafi in forum Nokia Lumia 720
    Replies: 0
    Last Post: 10-08-2014, 06:05 AM
  5. Paytm update lets you pay for most of the things
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-08-2014, 05:20 AM
LINK TO POST COPIED TO CLIPBOARD