1. WPCentral Question's Avatar
    I am from India. I have a Lumia 520 8.1. When I call to numbers out of India, they do not see my number, but get it as private number. I looked through many blogs and all of them direct to Settings -> Apps -> Phone and when I get here i should find an option to either hide or display my number. But apparently, I dont have any such option. Pls help so that I can unblock my number for my friends outside of the country. I dont have this issue when I call to people within the country.
    10-20-2014 01:41 PM
  2. jmshub's Avatar
    That doesn't sound like a setting in your phone, that sounds like a carrier setting. I'd contact your carrier to see what's up.
  3. jmshub's Avatar
    That doesn't sound like a setting in your phone, that sounds like a carrier setting. I'd contact your carrier to see what's up.
    Laura Knotek likes this.
    10-20-2014 02:28 PM

Similar Threads

  1. Is the call and network issue solved for Lumia 730?
    By WPCentral Question in forum Ask a Question
    Replies: 16
    Last Post: 12-25-2017, 02:05 PM
  2. Nokia Lumia 730 release in pakistan ?
    By Seasmy in forum Nokia Lumia 730 & 735
    Replies: 1
    Last Post: 10-24-2014, 02:31 AM
  3. On my 3rd Lumia 1520
    By Westarmy in forum Nokia Lumia 1520
    Replies: 3
    Last Post: 10-20-2014, 10:46 PM
  4. Why can't I get my HTC Radar to send pictures on Straight Talk?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 10-20-2014, 05:00 PM
  5. Replies: 0
    Last Post: 10-20-2014, 12:59 PM
LINK TO POST COPIED TO CLIPBOARD