1. Windows Central Question's Avatar
    I have a new BH-121, paired to a L1520 running the latest Developer Preview Cyan OS. The information for the BH-121 in the L1520's device hub constantly displays the battery as 3%, as does the live tile.
    Is this a bug with the DP OS, or do I have a faulty BH-121?
    12-29-2014 04:35 PM
  2. Pacus1x's Avatar
    It's not uncommon to find bugs on DP versions, most likely it's a bug in the phone. You could try to erase the BT device from your phone, soft reset and then pair it again maybe that could solve the battery info problem.
  3. Pacus1x's Avatar
    It's not uncommon to find bugs on DP versions, most likely it's a bug in the phone. You could try to erase the BT device from your phone, soft reset and then pair it again maybe that could solve the battery info problem.
    aximtreo and Laura Knotek like this.
    12-29-2014 08:12 PM
  4. Nikos Aba's Avatar
    same problem here!... any solution? soft/hard reset on either phone or bh-121 didn't solve this..... :( it's annoying...
    shivtej jagtap likes this.
    01-04-2015 06:51 AM
  5. ThanhND307's Avatar
    I have this problem too.
    My phone is Lumia 920 - Cyan firmware.
    It seem that this problem occur after I update the device hub app to version 3.6.3.5 on 2014/12/23. Before that, it work as expected.
    So I think it is a bug of the device hub app. We may need to wait for a bug fixing from Microsoft. :(
    01-06-2015 08:58 PM
  6. HansE's Avatar
    I have the same problem. Erasing the device doesn't help. We will have to wait for an update.
    01-14-2015 05:40 AM
  7. Gzhuang's Avatar
    My phone is Lumia 925 and I've got the same problem here. Hope they are going to fix it!
    02-05-2015 07:12 AM
  8. Laurent BALONCHARD's Avatar
    Same problem with Nokia Lumia 1320 since update.
    Hope it will be fixed quickly...
    Laurent.
    Last edited by Laurent BALONCHARD; 02-13-2015 at 01:21 PM.
    02-13-2015 11:29 AM

Similar Threads

  1. Replies: 12
    Last Post: 02-08-2015, 04:43 PM
  2. Do I have a Denim update on my Lumia 1520?
    By alexeysalo in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 01-05-2015, 03:11 PM
  3. Internet Explorer on phone is too bad
    By Prateek Kumar in forum Windows Phone 8.1
    Replies: 8
    Last Post: 12-31-2014, 12:55 AM
  4. Is there an app for compass in Nokia Lumia 635?
    By Windows Central Question in forum Ask a Question
    Replies: 10
    Last Post: 12-30-2014, 10:55 PM
LINK TO POST COPIED TO CLIPBOARD