1. Legoboyii's Avatar
    Which would get LTE with TMo, the version available on B&H or the AT&T L830 (unlocked)?

    I know the AT&T Lumia 635 (unlocked) gets LTE with TMo because I'm using it right now. :P
    01-09-2015 10:40 PM
  2. WanderingTraveler's Avatar
    It seems like the ATT 830 will get LTE on T-Mo, but I'll have to check further, unless the FCC listing is good enough.
    01-09-2015 10:48 PM
  3. Legoboyii's Avatar
    It seems like the ATT 830 will get LTE on T-Mo, but I'll have to check further, unless the FCC listing is good enough.
    I'd just like to know before dumping 400$ on one. xD
    And I want to gradually work my way up with screen sizes. 4.5" to 6" is a big jump so ill hold off on a 1520 or its successor and just grab a 830.
    I hope I can land its for say 300-350 at some point. 400$ for an 830 I'd rather just save a little more and grab a 1520 but.... yah :P
    01-09-2015 11:01 PM
  4. mark233's Avatar
    Here's a screen shot of my 830 RM-985 (from B&H Photo) T-Mobile test
    wp_ss_20150109_0001.png
    speed-test.png
    RumoredNow likes this.
    01-09-2015 11:14 PM
  5. Legoboyii's Avatar
    Here's a screen shot of my 830 RM-985 (from B&H Photo) T-Mobile test
    Click image for larger version. 

Name:	wp_ss_20150109_0001.png 
Views:	18 
Size:	542.5 KB 
ID:	93397
    Click image for larger version. 

Name:	speed test.png 
Views:	18 
Size:	34.3 KB 
ID:	93398
    Thanks, ill just have to save up for an rm-985 Lumia 830, hopefully for less than what B&H is asking for via eBay. But if not... Well not much choice there.
    Either way thanks a bunch.

    I just wish the 830s weren't so expensive x.x, they aren't worth the 450$ they ask for. 375 maybe but not 450... Jeez
    mark233 likes this.
    01-09-2015 11:48 PM
  6. Todd Sorrell's Avatar
    I have an 830 on T-Mobile, but I can't get LTE. Did you have to go with manual APN settings? Thanks.
    02-26-2015 04:37 PM
  7. mark233's Avatar
    I have an 830 on T-Mobile, but I can't get LTE. Did you have to go with manual APN settings? Thanks.
    My RM-985 got U.S.T-Mobile LTE right out of the box ... no manual APN settings input. Try soft reset?
    02-26-2015 05:31 PM
  8. Todd Sorrell's Avatar
    Tried a soft reset. Still no LTE. And not even H+ or H, but E right now...

    Can you post a screen shot of your APN settings? I've tried the default, and also manually changing them to what T-Mobile has on their site. I'm beginning to wonder if I truly have a 985... Thanks.
    02-27-2015 11:52 AM
  9. mark233's Avatar
    Tried a soft reset. Still no LTE. And not even H+ or H, but E right now...

    Can you post a screen shot of your APN settings? I've tried the default, and also manually changing them to what T-Mobile has on their site. I'm beginning to wonder if I truly have a 985... Thanks.
    Sure
    830-vpn-settings.png
    You could also try removing your SIM and reinstall it.
    02-27-2015 05:37 PM
  10. Todd Sorrell's Avatar
    Thanks.

    That's exactly what mine had as default. Can't get LTE with that setting. It's not what T-Mobile has on their site for setting BYOD data settings, which I have also tried and can't get LTE. I think it's time to call T-Mobile tech support. Thank you again for your help.
    02-27-2015 06:25 PM
  11. AR2186's Avatar
    If you are going to get an 830 for the US, you may want to pick it up directly from Microsoft unlocked. You get all the benefits of B&H but get the US warranty.

    That said, why not just get a 1520 and save yourself the money of the intermediate step. It takes some getting used to but I keep switching my sin back to my 1520 from my Icon because of the screen. Its awesome.

    Here is the Microsoft store link to the 830
    http://forums.windowscentral.com/e?l...token=LY6bPDYe
    02-27-2015 06:43 PM
  12. mark233's Avatar
    Maybe try factory reset? Using Nokia Software Recovery Tool
    02-27-2015 08:01 PM
  13. Todd Sorrell's Avatar
    So finally got this working. I went to Settings/Cellular + SIM/SIM Settings. On that screen there is a dropdown for 'Network selection', which was defaulted to T-Mobile, which is why I never looked at it. I selected "Search for Networks" in that dropdown and when it finished searching it was still on T-Mobile, but LTE was working. Been working great ever since.
    RumoredNow and mark233 like this.
    03-23-2015 12:51 PM

Similar Threads

  1. Why does my Lumia 1020 automatically starts taking photos?
    By vyjayanthi srinivasan in forum Nokia Lumia 1020
    Replies: 5
    Last Post: 01-11-2015, 11:08 AM
  2. How do I get off of my lock screen (I'm stuck on it, 925)?
    By tomval2k in forum Nokia Lumia 925
    Replies: 3
    Last Post: 01-10-2015, 02:27 PM
  3. Just got Rm-1045 Lumia 930 from HK had some questions
    By siber storm in forum Nokia Lumia 930
    Replies: 3
    Last Post: 01-10-2015, 10:52 AM
  4. Why does my email disappear from my Lumia 925 after a few days?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-10-2015, 12:50 AM
  5. Why don't I have Cortana on my Windows 8.1 Lumia 920?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-09-2015, 10:12 PM
LINK TO POST COPIED TO CLIPBOARD