1. Windows Central Question's Avatar
    I have had my Lumia 1020 for 13 months and recently it has been running very slowly. Now apps won't open - I click on them and get a black screen with 'loading...' in the middle. Either they take so long to load that my phone ends up on the lock screen or they fail to open and it goes back to the start menu.

    This happens about 60% of the time and is getting very frustrating. Any help would be much appreciated.
    03-17-2015 06:08 PM
  2. RobinPaul's Avatar
    Might have to do a backup/reset/restore on your phone (this will also make you phone faster as it will delete old system files and temp files). just a suggestion.
    03-17-2015 10:13 PM
  3. xandros9's Avatar
    03-17-2015 11:05 PM

Similar Threads

  1. AT&T 635 on TMO Wifi calling?
    By gibbage in forum Nokia Lumia 635
    Replies: 8
    Last Post: 03-21-2015, 09:34 PM
  2. Clearing the band on Android phone
    By bksalt in forum Microsoft Band & Band 2
    Replies: 7
    Last Post: 03-18-2015, 11:58 AM
  3. Why won't my 735 recieve calls or texts
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 03-17-2015, 07:41 PM
  4. Where can i find a stylus for my Surface RT, to use with OneNote?
    By Windows Central Question in forum Microsoft Surface for Windows RT
    Replies: 1
    Last Post: 03-17-2015, 06:04 PM
  5. Xbox 360 YouTube app gets a design overhaul in latest update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-17-2015, 05:30 PM
LINK TO POST COPIED TO CLIPBOARD