1. Windows Central Question's Avatar
    I just bought a brand new one today but when I got it the battery was dead. I've been having to charge it up all day but it's taken about 6 hours to get to 58% and as soon as I unplug it it'll drains mega fast! The weird thing as well is it gets really hot when charging, hotter than any phone I've ever had before.
    06-09-2015 02:56 PM
  2. gpobernardo's Avatar
    Some further testing may be required to verify if your L1020 is indeed faulty or not.

    Try charging your phone while in Airplane Mode. I've experienced the same symptoms as yours but only when my L1020 is in an area that has weak GSM signals. Enabling airplane mode should eliminate antenna-related power problems (which also causes excessive heating problems). Your phone should charge to 100% in an hour or so (depending on starting charge level) with only a mild generation of heat.
  3. Topataco's Avatar
    Try a hard reset before returning it. But yes that is not supposed to be happening if it's brand new
    06-09-2015 03:11 PM
  4. gpobernardo's Avatar
    Some further testing may be required to verify if your L1020 is indeed faulty or not.

    Try charging your phone while in Airplane Mode. I've experienced the same symptoms as yours but only when my L1020 is in an area that has weak GSM signals. Enabling airplane mode should eliminate antenna-related power problems (which also causes excessive heating problems). Your phone should charge to 100% in an hour or so (depending on starting charge level) with only a mild generation of heat.
    Harrie-S likes this.
    06-09-2015 03:13 PM
  5. Miffywiffy's Avatar
    It's drained 50% in 2 and a half hours of just being idle and the battery saver showing basically nothing has been running.

    When I charge the phone it gets mega hot....


    Sucks because trying to get a refund is gonna be a nightmare I bet.
    06-09-2015 06:35 PM
  6. gpobernardo's Avatar
    It's drained 50% in 2 and a half hours of just being idle and the battery saver showing basically nothing has been running.

    When I charge the phone it gets mega hot....


    Sucks because trying to get a refund is gonna be a nightmare I bet.
    Have you... tried charging... your phone... in Airplane mode...?
    06-10-2015 03:12 PM
  7. Miffywiffy's Avatar
    Have you... tried charging... your phone... in Airplane mode...?
    My signal is good, it's Data only on my network any ways.

    The phone was faulty I sent it back.
    gpobernardo likes this.
    06-11-2015 04:35 PM

Similar Threads

  1. Installed Windows 10 on Surface 3....Have Questions
    By chobo2 in forum Windows 10 Insider Preview
    Replies: 8
    Last Post: 06-21-2015, 12:19 PM
  2. Microsoft puts its name on the old Nokia Theater in Los Angeles
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-09-2015, 01:42 PM
  3. Does 640 have active noise cancellation?
    By siddhant patil in forum Microsoft Lumia 640
    Replies: 1
    Last Post: 06-09-2015, 12:45 PM
  4. Microsoft headphones: I have questions...
    By Mitesh Somani1 in forum Windows Phone Accessories
    Replies: 2
    Last Post: 06-09-2015, 12:00 PM
LINK TO POST COPIED TO CLIPBOARD