1. WPCentral Question's Avatar
    Yesterday I update my Windows 8.0 to 8.1 and then to 10 after my update to Windows 10 was nearly finish something went wrong. It skipped a last step and went straight to the wallpaper and for a while it didn't move to unlock or anything but now it's finally partially working. I can't open the majority of my apps and my phone doesn't want to connect to my wifi. I would reset my phone but somehow my settings got uninstall. help please.
    06-25-2015 12:12 PM
  2. worldspy99's Avatar
    Reset it back to WP8.1 and wait for a more polished version of Win10mobile on your Lumia 520.
    06-25-2015 12:38 PM
  3. Walson Valmy's Avatar
    How? my settings is gone.
    06-25-2015 12:46 PM

Similar Threads

  1. Lenovo posts renders of a ThinkPad Time Machine, looks to gauge consumer interest
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 06-25-2015, 12:26 PM
  2. A quick look at Amzer's Pudding TPU Case for Lumia 830
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-25-2015, 12:11 PM
  3. Can I send .gif MMS?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-25-2015, 11:51 AM
  4. Why doesn't my screen display on my 520?
    By Windows Central Question in forum Nokia Lumia 520
    Replies: 1
    Last Post: 06-25-2015, 11:18 AM
  5. Everything you need to know about Gears of War: Ultimate Edition
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-25-2015, 11:11 AM
LINK TO POST COPIED TO CLIPBOARD