1. tmulhearn's Avatar
    Just got a 435, the lights on the bottom for back, home , search don't light up. Is that normal?
    08-13-2015 03:03 PM
  2. Qtweeder's Avatar
    unfortunately so, they are just inanimate (no led), had to get rid for that reason alone, and go for a 2nd hand 920 for my father instead.
    tmulhearn likes this.
    08-13-2015 03:07 PM
  3. tmulhearn's Avatar
    I can live with it if that's the norm, I'm using it as a music player only, but was initially shocked as my 1520 glows brilliantly . Thank you for the reply. I find it very odd though
    Qtweeder likes this.
    08-13-2015 03:14 PM
  4. Qtweeder's Avatar
    no probs, yes that's how its meant to be, looks like only the higher end devices get the led buttons!
    08-13-2015 03:17 PM
  5. tmulhearn's Avatar
    Fair enough, thanks
    08-13-2015 03:23 PM

Similar Threads

  1. Replies: 11
    Last Post: 11-18-2015, 12:21 AM
  2. 8 Zip file archiver is now available for Windows 10 in free and paid versions
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-13-2015, 03:00 PM
  3. Why aren't videos working properly online?
    By Windows Central Question in forum General Phone Discussion
    Replies: 0
    Last Post: 08-13-2015, 02:52 PM
  4. I tried to install windows 10 and now my computer won't start
    By Pierre-Olivier Gagnon in forum Windows 10
    Replies: 0
    Last Post: 08-13-2015, 02:36 PM
  5. Replies: 0
    Last Post: 08-13-2015, 02:21 PM
LINK TO POST COPIED TO CLIPBOARD