1. Windows Central Question's Avatar
    I just received back my Lumia 820 after an USB connector replacement (it was jammed and couldn't charge the phone).

    Ever since then I have no internet on the phone. It shows as if it would connect to the Wireless network, but I have no Internet connection on the phone itself.
    I get an IP like 169.254.x.x and a mask with 255.255.0.0
    ...which would indicate an APIPA/ DHCP issue according to my limited IT knowledge.

    Problem is that there are 3 other devices (a laptop, a PC and my girlfriend's Lumia 640) connected to the same Wireless Router and they all work just fine, while my L820 has no internet connection.
    I've tried with my other network at my old flat, got the same issue (IP and mask-wise).
    The network is not limited by MAC Addresses as those devices connected just automatically and they all work fine. And the number of devices connected are also not limited as I've tried disconnecting a device while connecting with my phone - same result.

    Is it possible then that it is a hardware issue and the guys fixing my phone messed something up with the WiFi? What can I do to solve this?

    Thanks in advance for your input!
    08-31-2015 01:58 PM

Similar Threads

  1. Microsoft's Bing engine is ready to predict the winners of the 2015 NFL football season
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-31-2015, 01:42 PM
  2. How can I find my printer? I lost it after window 10 upgrade
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-31-2015, 01:21 PM
  3. Replies: 0
    Last Post: 08-31-2015, 01:17 PM
  4. Replies: 1
    Last Post: 08-31-2015, 01:11 PM
LINK TO POST COPIED TO CLIPBOARD