1. Windows Central Question's Avatar
    My lumia 920 started presenting with a weird problem today. I am currently on wp 8.1 update. My OS version is 8.10.14234.375. So everything was working fine today morning but in the afternoon i lost my Service signals and it kept showing 'NO Service'. So i turned the airplane mode ON and then back OFF. After that i regained my Signal strength. After some time i again lost my Service and again i repeated the same procedure and regained service. After that i did a soft reset. Since the soft reset the problems have escalated. I cant open most of my app. Most of the 3rd party apps have stopped working. Whenever i open an app the app appears as it will start but suddenly it exits out to the Home Screen. Now even some of the system apps are not starting namely the MS Camera and Music. Sometimes the Home Screen just goes blank and nothing happens, only the Status Bar is visible. I need to restart the phone in order to get the Home Screen back ON. I updated a couple of apps yesterday night i.e. Telegram and Lumia Cinemagraph. I uninstalled both of them but still nothing has improved. Can somebody please help as to what i should do?? I need to check out all other options before performing the dreaded Hard Reset.
    09-01-2015 08:39 AM

Similar Threads

  1. Why is popcorn time down for my lumia 535?
    By Burek018 in forum Ask a Question
    Replies: 2
    Last Post: 09-01-2015, 08:53 AM
  2. When can i expect wp10 update on my uk tesco lumia 640?
    By voodoocars in forum Windows 10 Mobile
    Replies: 2
    Last Post: 09-01-2015, 07:32 AM
  3. Why isn't my Lumia 520 starting?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 09-01-2015, 07:06 AM
LINK TO POST COPIED TO CLIPBOARD