1. forsalead's Avatar
    Hope this is not a dup of my own but I think I failed to submit my question earlier:

    I bought Blu Win HD almost a year ago. Love the phone and it worked great.
    I used the phone on LycaMobile but never used it with data connectivity.

    Yesterday I made the switch to T-Mobile with a data plan.

    To my disappointment, I am getting extremely slow network speed. Been talking to T-Mobile folks and they claim its not a supported Phone so believe its a phone issue.

    I find it odd .. Why would Blu make a smart phone that claims to support all major networks in the US but will give not make it work reasonably on T-Mobile.

    Ok, lets talk numbers and phone:

    This is Blu Win HD 510u (Not LTE)
    Ping time: 550ms
    Upload speed: 0.13mbs
    Download: 0.14mbs

    The bar shows 2-4 bars but with "E" (edge?)

    Do others have better experience with Blu (not LTE) and Tmobile? What speeds you are seeing? what configuration you have?

    Really trying to avoid the ping-pong between Blu and T-Mobile if I can.

    (BTW: Blu Win JR - behaves much better for me)
    09-03-2015 08:08 PM
  2. RumoredNow's Avatar
    Most likely it is your APN...

    BLU Win HD supports T-Mo H+.

    If your APN is "fast.t-mobile.com" it is an LTE APN and you don't have LTE. New SIMs from T-Mo would autoset to this.

    You want the previous (legacy) APN

    Go into Settings > cellular + SIM > SIM (1 or 2 depending, you don't really say)

    Enable Manual APN. Edit "internet APN" and "MMS APN" to the following:




    If you need to add additional information or want to post additional questions, please join the site so you can see the reply button and continue the conversation in the same thread you originally made.
    Attached Thumbnails capture.png  
    oviedofreak82 and forsalead like this.
    09-03-2015 08:25 PM
  3. vipme's Avatar
    Blu WIN HD 510u
    Your phone probably does not support the 3G band that T-Mobile uses for cellular data, i guess its the 2100MHz band
    http://www.gsmarena.com/blu_win_hd-6669.php
    Technology GSM / HSPA
    2G bands GSM 850 / 900 / 1800 / 1900
    3G bands HSDPA 850 / 1900 / 1700 - W510U
    3G bands HSDPA 850 / 1900 / 2100 - W510L
    forsalead likes this.
    09-03-2015 09:16 PM
  4. forsalead's Avatar
    Thanks.

    this is the setting I have. I went to the store and asked them to double check.

    Does t work better for you?

    thanks
    09-03-2015 09:22 PM
  5. RumoredNow's Avatar
    I'm mot on T-Mo or using that phone...

    Maybe another user will have more hands on advice. Sorry, I didn't help.
    forsalead likes this.
    09-03-2015 09:27 PM
  6. forsalead's Avatar
    Found this discussion on the T-mobile fourms. Still very confusing the follow but the answer marked as "correct" answer suggests 1900 is the frequency needed for 3G.
    But then there are discussion it might need 1900 and 2100?

    Still hoping to find users in this group who are using it on t-mobile (US)

    Don't know how to post a link here.
    09-04-2015 09:51 AM
  7. vipme's Avatar
    "correct" answer suggests 1900 is the frequency needed for 3G
    sometimes it also depends from area to area, somewhere they use 1900 MHz band for 3G, somewhere else the same frequency for 4G/LTE, and you end up with only 2G and 4G networks but no 3G

    on one of my phones if i go to the country side i don't have coverage, can't even make calls, but at the same time on my other device i have 4G and full signal on same carrier in the same place, inside cities no problems tho

    Don't know how to post a link here.
    You need 10+ posts to be able to publish links and images on forum. Guess its kind of a protection against spammers.
    09-04-2015 11:52 AM
  8. forsalead's Avatar
    Was on the phone this morning with the Blu folks - they gave me the standard process, change the APN setting, reset the phone (their way as opposed to the normal rest - don't think there is a difference) and its all the same.
    But I did ask them what type of connection I should expect and they claim 3G.

    I might go to a MS store and try my sim on one of their phones.

    btw: Should this post be here or the Blu Win HD forum? Can it be moved? (new here, 6 more posts before I can even include a link here )
    09-04-2015 07:20 PM
  9. forsalead's Avatar
    Going to the MS Store turned out the be the best move. Those guys are amazing. They know sometimes some of the phones don't pick some of the frequencies and they switched the phone without argument and ... its works.

    very happy with how they handled it. No more ping pong between the different companies.
    09-05-2015 02:26 PM

Similar Threads

  1. Replies: 1
    Last Post: 09-03-2015, 07:19 PM
  2. Where is enable editing on Windows 8.1?
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 09-03-2015, 05:46 PM
  3. Replies: 1
    Last Post: 09-03-2015, 05:29 PM
  4. How can I fix error code 805a0194?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 09-03-2015, 04:44 PM
LINK TO POST COPIED TO CLIPBOARD