1. zeuxiss's Avatar
    Hi..both my laptop and desktop didn't recognize my L1520 BUT both of them recognize my L535..either i use the same data cable or another data cable,the result is the same,both desktop and laptop didn't recognize my L1520..
    1. What is the problem??
    2. How can I solve this?
    Last edited by zeuxiss; 09-13-2015 at 12:46 PM.
    09-13-2015 12:34 PM
  2. gpobernardo's Avatar
    0. Have you tried restarting or performing a soft reset on your Lumia 1520? Does your phone still charge?

    1. It appears that the problem is with your phone, particularly the mini-USB port - thanks for the definitive information.

    2.a. Check that there is no accumulated dirt in the port. If there is, use a piece of folded paper to try to clean it (do not use hard metallic objects - we don't want to damage or misalign the pins).
    2.b. Use an aspirator to force air into the port, in an attempt to blow the dirt out. Use a can of compressed air if necessary. Do NOT blow into the port using your mouth and straw (moisture may get into the phone, and we all know what would happen next).

    If these don't work, you may need to bring your phone to a service center, informing them accurately about your findings - so they would know exactly what to do.
    RumoredNow likes this.
    09-13-2015 12:54 PM
  3. zeuxiss's Avatar
    0. Have you tried restarting or performing a soft reset on your Lumia 1520? Does your phone still charge?

    1. It appears that the problem is with your phone, particularly the mini-USB port - thanks for the definitive information.

    2.a. Check that there is no accumulated dirt in the port. If there is, use a piece of folded paper to try to clean it (do not use hard metallic objects - we don't want to damage or misalign the pins).
    2.b. Use an aspirator to force air into the port, in an attempt to blow the dirt out. Use a can of compressed air if necessary. Do NOT blow into the port using your mouth and straw (moisture may get into the phone, and we all know what would happen next).

    If these don't work, you may need to bring your phone to a service center, informing them accurately about your findings - so they would know exactly what to do.
    Yes, I already tried the soft reset but failed. I already clean my phone's port.

    There is one weird thing, when I pltake out my SD Card, the computer recognized my phone.
    09-14-2015 10:52 AM
  4. gpobernardo's Avatar
    Peculiar... what OS version is your L1520 running? Did you install TP?
    09-14-2015 11:44 AM
  5. zeuxiss's Avatar
    Peculiar... what OS version is your L1520 running? Did you install TP?
    I am using WP8.1 Update, OS Version 8.10.14226.359. I want to hard reset my phone first when I am not busy. And if the problem still there, I want to hard reset my phone AND also format my SD Card.
    gpobernardo likes this.
    09-15-2015 12:28 PM
  6. ads13's Avatar
    I think it would be probably your memory card's problem.
    09-15-2015 12:45 PM
  7. zeuxiss's Avatar
    I think it would be probably your memory card's problem.
    I don't know how to check it. But as far as i know, my memory card works flawlessly.
    09-15-2015 01:15 PM
  8. ads13's Avatar
    So,then go to your nearest MS care...
    09-15-2015 02:36 PM
  9. gpobernardo's Avatar
    I am using WP8.1 Update, OS Version 8.10.14226.359. I want to hard reset my phone first when I am not busy. And if the problem still there, I want to hard reset my phone AND also format my SD Card.
    First try reformatting your SD Card using your phone - this is easier than performing a hard reset on your phone. This also would ensure that your SD Card is in the correct format. Also try using different SD Cards.

    If these don't work, then you could proceed with performing a hard reset on your phone. If that still doesn't work, then you may need to go to a service center to have that issue checked.
    zeuxiss likes this.
    09-16-2015 08:05 AM
  10. zeuxiss's Avatar
    First try reformatting your SD Card using your phone - this is easier than performing a hard reset on your phone. This also would ensure that your SD Card is in the correct format. Also try using different SD Cards.

    If these don't work, then you could proceed with performing a hard reset on your phone. If that still doesn't work, then you may need to go to a service center to have that issue checked.
    Thanks,sir. I will try to format my SD Card first. If my phone still has the problem, I will try the other methods that you said. One more time, thanks
    gpobernardo likes this.
    09-17-2015 10:30 AM

Similar Threads

  1. Microsoft all apps are on Android But why not Google all apps on Windows Phone?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-13-2015, 02:02 PM
  2. Microsoft all apps are on Android But why Goolgle apps on Windows Phone?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 09-13-2015, 12:21 PM
  3. Replies: 0
    Last Post: 09-13-2015, 12:00 PM
  4. Replies: 1
    Last Post: 09-13-2015, 11:42 AM
  5. I am using Windows Phone 10. I can't find my cellular setting. Where is it?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-13-2015, 11:09 AM
LINK TO POST COPIED TO CLIPBOARD