1. Windows Central Question's Avatar
    Hi there,
    I just bought Surface Pro 4 i7 512GB and realized my wifi diconnects as soon as i plug in USB 3.0 drive. I did some investigation and found, it is becuase I am using 2.4 GHz wifi netowrk. This problem disappears when using 5.0 GHz wifi netowrk. I also own Surface Pro 3 and it is working fine even when using 2.4 GHz wifi and USB 3.0 stick.
    MY question(s): is it common problem with all the Surface Pro 4 devices or only some? Is it some insulation/shielding problem? DO I need to send back to Microsoft for a replacement? I am not sure if I should accept such issues after paying premium price? Please advice.

    Thanks a lot in advance!
    12-12-2015 07:29 PM
  2. gkarg's Avatar
    Hi
    You are not the only one, with this problem - see answers.microsoft.com/thread/a532fab4-b41f-4f8c-a5bf-0bd559b49d74
    I have ordered a replacement at the Microsoft Support, which will arrive around 28/29 next week. The support confirmed, that this is not a general problem - as soon as the replacement arrives, i will kniw, if this is true or not. I will post the result next week.
    Gkarg
    12-25-2015 01:42 AM
  3. gkarg's Avatar
    Hi
    the replacement unit arrived - same problem.
    Gkarg
    12-31-2015 03:39 AM

Similar Threads

  1. Will the Icon work with AT&T?
    By Lumious in forum Nokia Lumia Icon
    Replies: 12
    Last Post: 01-13-2016, 01:22 AM
  2. Replies: 1
    Last Post: 12-13-2015, 01:22 AM
  3. Private cloud with good WP support?
    By bigdnf in forum General Phone Discussion
    Replies: 6
    Last Post: 12-12-2015, 10:49 PM
  4. Screen flush with edges?
    By paddylaz in forum Microsoft Lumia 950 XL
    Replies: 1
    Last Post: 12-12-2015, 04:52 PM
  5. Microsoft is currently dealing with Xbox Live friends list issues
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-12-2015, 04:42 PM
LINK TO POST COPIED TO CLIPBOARD