1. Windows Central Question's Avatar
    I recently had a bad battery in BLU Win HD LTE phone. I sent it in for service and they returned it this week (pretty sure it's a completely different/new phone, but whatever).

    Of course all the data is lost from my original phone. No problem, I insert my SIM and SD card and startup the phone. But as soon as I try to login with my MS account, it stops and says it requires an activation code. After a long round of phone calls I managed to acquire a 20-digit activation code from MS. So I go back to trying to setup my phone again and this time I input the activation code. It seems to accept it but just spins forever (the five little dots cross the screen and never stop). Eventually I hit the back arrow and it shows me now logged in and good. HOWEVER: I find I have NO option to restore my last backup. No matter how many times I rehash this, I end up having to input the activation code if I hard/soft reset the device and wind up with no option to restore a prior backup.

    If I go to my temporary phone I used while waiting for the replacement (BLU Win JR) I can see that there are indeed recent backups available.

    So with no way to restore my account settings via hard reset...Is there some way to manually force a restore without a reset? It seems to me the activation piece is messing something up...?
    02-12-2016 12:28 PM
  2. RumoredNow's Avatar
    If you have a replacement device the IMEI may be throwing it off.

    Try this... Settings > system > about > edit name> make sure the device has the same name as the one that you see a backup for.

    BTW, you can also see what backups you have by logging into OneDrive in your browser > click on the amount of available storage and select Device Backups...


    If you need additional help or have more questions or details to share, please join the site so you can reply in this thread... Please see this link for instructions on how to join Windows Central.
    02-12-2016 04:42 PM
  3. rjzeller's Avatar
    Hey, thanks for the reply. That was my question above. I did find that the phone was a different name than my old phone. So next question is, after changing the name to match...what next? Do I need to perform a reset on the phone again or is there some way to get it to sync up and pull the backup?
    02-12-2016 05:21 PM
  4. RumoredNow's Avatar
    Maybe just a Soft Reset. Hold the Volume Down + Power buttons until the phone vibrates and reboots (about 10 seconds). You won't loose data.

    Then try the backup. I'm not sure if the IMEI will throw it off. Technically you should be able to pull the backup from any phone on your Microsoft Account. Using the same name might be enough of a trick...
    02-12-2016 11:16 PM

Similar Threads

  1. Why can't my user account log in?
    By Windows Central Question in forum Windows 10
    Replies: 1
    Last Post: 02-12-2016, 04:33 PM
  2. IE Favourites on Windows 10 and Windows Phone 8.1
    By Per Kjellqvist in forum Windows Phone 8.1
    Replies: 1
    Last Post: 02-12-2016, 01:48 PM
  3. Replies: 1
    Last Post: 02-12-2016, 11:12 AM
  4. Replies: 0
    Last Post: 02-12-2016, 10:42 AM
  5. Satisfy your need for two-wheel speed with Traffic Rider for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-12-2016, 08:11 AM
LINK TO POST COPIED TO CLIPBOARD