1. Windows Central Question's Avatar
    when the phone is set to 4G in highest connection speed immediately it loses network. then have to reboot and then set to 3G before it works again. and after a while it automatically changes to 4G and loses network showing SIM error. i am really annoyed and disappointed with this. i hate MS now.
    02-16-2016 04:01 PM
  2. fatclue_98's Avatar
    That's your carrier, not your phone. Microsoft does not make your cellular radios nor does it control the airwaves. If you're losing your 4G signal but can maintain the fallback 3G, you're having a coverage problem.
    02-16-2016 04:05 PM

Similar Threads

  1. 6tin 2.10.0.3 crashes on Lumia 735, anyone else having this problem?
    By kefkekeyser in forum Nokia Lumia 730 & 735
    Replies: 13
    Last Post: 02-18-2016, 01:24 PM
  2. GPS isn't recording accurate mileage on runs?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-16-2016, 04:31 PM
  3. The 10 best action/adventure games on the Xbox One
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-16-2016, 03:42 PM
  4. How to download Xbox One achievement images on full HD in Windows 10 without an app
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-16-2016, 03:42 PM
  5. I ditched my Surface and only used Continuum on my Lumia here's how it went
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-16-2016, 01:50 PM
LINK TO POST COPIED TO CLIPBOARD