1. Windows Central Question's Avatar
    I tried to install Adblock from the Windows Store, but Edge does not recognize that there is a new extension.

    I use Edge on the Anniversary Update.

    The store (in its download history) says that Adblock needs a repair. So I re-install it, but to not avail.
    08-02-2016 01:59 PM
  2. Bacso Marton's Avatar
    Thank God, I am not the only one... There must be some kind of error with UWP apps. I get the same error message with EDGE extensions AND although I can install other applications from the store I can't run them, they just close themselves. Old ones run without any problems.
    08-02-2016 02:24 PM
  3. theefman's Avatar
    Checked for updates? Might be an issue fixed in the update that was released yesterday.

    Sent from mTalk
    Chintan Gohel likes this.
    08-02-2016 02:34 PM
  4. Bacso Marton's Avatar
    Yes, and there is no other update available. I also tried to restart the computer as well. I am not in the Windows Insider program and I got Anniversary Update through Windows Update an hour ago.
    08-02-2016 02:38 PM
  5. Great deal's Avatar
    Same issues with all extentions, so much for fixing bugs, what have they been doing for 12 months lol - my SP4 installation seems stuck on a black screen with spinnging gear as well :/ not good
    08-02-2016 02:56 PM
  6. Thomasso's Avatar
    You're not alone.
    I tried running the windows store troubleshooter:
    Didn't help any.

    Tried running wsreset.exe from cmd
    nothing.

    Even tried dism /online /cleanup-image /restorehealth

    Running out of ideas of what to do about it
    08-02-2016 02:58 PM
  7. etphoto's Avatar
    That was the first thing I did after updating my two computers was to install adblock. Thank goodness it worked for me.

    Sent from mTalk
    Chintan Gohel likes this.
    08-02-2016 03:14 PM
  8. Great deal's Avatar
    Think this is more than a few people... the advice here doesnt help either... Cortana is screwed on both Desktop AND SP4, I dont have anything other than Office 365 on it lol

    http://www.windowscentral.com/window...oblems-how-fix
    08-02-2016 03:53 PM
  9. Mathe172's Avatar
    Had the same problem. What fixed it for me: (no idea which steps are necessary)
    • Clear cache
    • Close Edge
    • Install extension (directly from the store)
    • Press "Start" after the extension is installed (the button in the store that replaces "Install")


    Hope this also fixes it for some others...
    Chintan Gohel likes this.
    08-03-2016 02:46 AM
  10. Grodelj's Avatar
    Found a solution on reddit which worked for me:

    Go to Settings -> System -> Apps and Features, and uninstall all extensions.
    Close all open applications, and open a Powershell window as administrator.
    Run wsreset.exe. The Windows Store should pop up after a few moments.
    Re-open Edge, and download extensions.
    Chintan Gohel and Great deal like this.
    08-03-2016 03:13 AM
  11. Great deal's Avatar
    Found a solution on reddit which worked for me:

    Go to Settings -> System -> Apps and Features, and uninstall all extensions.
    Close all open applications, and open a Powershell window as administrator.
    Run wsreset.exe. The Windows Store should pop up after a few moments.
    Re-open Edge, and download extensions.

    As above without the powershell command, should work just by uninstalling and reinstalling from store, only uninstall the extentions that dont work.
    Chintan Gohel likes this.
    08-03-2016 07:48 AM
  12. garak0410's Avatar
    Found a solution on reddit which worked for me:

    Go to Settings -> System -> Apps and Features, and uninstall all extensions.
    Close all open applications, and open a Powershell window as administrator.
    Run wsreset.exe. The Windows Store should pop up after a few moments.
    Re-open Edge, and download extensions.
    This got me past the REINSTALL button and shows LAUNCH but the Extensions do not appear in Edge. :( In fact, if I go back to the store for the extension, it shows REINSTALL once again. :(
    08-03-2016 02:13 PM
  13. speccy's Avatar
    I realise this isn't very helpful, but I installed Adblock on Edge without any issues, so it must work for a few people I guess. Just waiting for a proper addon/extension from EnPass now. The installation of the current Enpass extension is messy to say the least.
    08-04-2016 10:28 AM
  14. Demian Mioc's Avatar
    Go to Pc>Local disk C>Windows>Software Distribution and delete folder called Data Store with some deleter software like Unlocker or Iobit Delete. Restart PC and try to download extensions again. Hope it helps!*Note: Before doing that, try to backup that folder or do a System restore point.
    08-04-2016 11:08 AM

Similar Threads

  1. How to sign in?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-03-2016, 06:32 AM
  2. Why have my emails all of a sudden stopped coming in, other than a random one.
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-03-2016, 05:52 AM
  3. Install Windows 10 Build 10586 From Build 10240
    By Susan64 in forum Windows 10
    Replies: 2
    Last Post: 08-02-2016, 03:03 PM
  4. Microsoft HoloLens Development Edition can be bought by any developer in U.S. and Canada
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-02-2016, 01:42 PM
  5. How can I remove MSN from my Edge News Feed? Way too liberal.
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-02-2016, 01:33 PM
LINK TO POST COPIED TO CLIPBOARD