1. Windows Central Question's Avatar
    So I've updated my Lumia Icon to Win10 a couple weeks ago and it worked quite fine.

    Today I've found my phone at 17% battery charge. Plugged it in and forgot about it for a while. Couple hours after - 12%! Went to the battery saver setting and saw (plugged in, not charging) message next to the battery charge percentage.

    Replaced the battery - same problem. Computer sees the data from phone as usual. Tried a different USB cable - same story. Tried to charge it with a wireless charger that worked just fine for me recently - same issue. Did a regular restart, and a couple of soft resets - nothing changed. Not sure what else I can do now. Don't want to do hard reset until it's the absolutely last chance.

    Any ideas guys?
    08-05-2016 04:07 PM
  2. BluWarrior's Avatar
    You might have to do a hard reset sadly :/ You have tried all the troubleshooting steps I can think of save that. You could try taking it into a Verizon shop and seeing if they can fix it.

    If you do a hard reset I'd use the Windows Device Recovery Tool. It would put your phone back on 8.1, but you can update again and that way if there's an issue with the firmware it will be fixed. Another benefit is once you get to 10 you could reset and get the much more polished version of 10 (Many issues happen when upgrading from 8 and not resetting) and then you could restore from your backup because a backup is just settings in 10 not an image so it would run much better.
    RumoredNow and libra89 like this.
    08-05-2016 06:01 PM
  3. Chintan Gohel's Avatar
    So I've updated my Lumia Icon to Win10 a couple weeks ago and it worked quite fine.

    Today I've found my phone at 17% battery charge. Plugged it in and forgot about it for a while. Couple hours after - 12%! Went to the battery saver setting and saw (plugged in, not charging) message next to the battery charge percentage.

    Replaced the battery - same problem. Computer sees the data from phone as usual. Tried a different USB cable - same story. Tried to charge it with a wireless charger that worked just fine for me recently - same issue. Did a regular restart, and a couple of soft resets - nothing changed. Not sure what else I can do now. Don't want to do hard reset until it's the absolutely last chance.

    Any ideas guys?
    hard reset might not fix a hardware issue - you've tried different cables, chargers, different battery - the charging system could be broken

    Can you charge the spare battery externally?

    If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Windows Central.
    08-06-2016 08:04 AM

Similar Threads

  1. Nokia Lumia 625 screen non responsive?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-06-2016, 07:59 AM
  2. Windows Ink Workshop on Surface 4 and Dell
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-06-2016, 04:51 AM
  3. windows 10 Freezeing after anniversary update
    By efuhrimann in forum Windows 10
    Replies: 2
    Last Post: 08-05-2016, 05:06 PM
  4. AT&T slashes the price of its Lumia 950 down to just $299 without a contract
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-05-2016, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD