1. Windows Central Question's Avatar
    When I connect my Lumia 640 to my PC (both running 8.1), it sees the phone in the disconnect area but doesn't show up in Windows explorer as a separate drive. (It usually says Windows Phone.)

    I also tried connecting my Android phone and the PC didn't see it at all.

    Both phones charge when connected.

    Up until today, both phones connected fine and I could transfer data between them and the PC.

    How can I fix this?
    08-25-2016 07:58 AM
  2. Maurizio Troso's Avatar
    When I connect my Lumia 640 to my PC (both running 8.1), it sees the phone in the disconnect area but doesn't show up in Windows explorer as a separate drive. (It usually says Windows Phone.)

    I also tried connecting my Android phone and the PC didn't see it at all.

    Both phones charge when connected.

    Up until today, both phones connected fine and I could transfer data between them and the PC.

    How can I fix this?
    Try changin usb ports or cables.
    Reboot your pc
    Chintan Gohel likes this.
    08-25-2016 08:01 AM
  3. fbrown627's Avatar
    I tried rebooting all the devices and used different cables. No luck.

    The PC only has one USB port.

    I should add that my Kobo ereader and "My Passport" HD work fine. It's just the phones that are having a problem.
    08-25-2016 08:13 AM
  4. Chintan Gohel's Avatar
    I tried rebooting all the devices and used different cables. No luck.

    The PC only has one USB port.

    I should add that my Kobo ereader and "My Passport" HD work fine. It's just the phones that are having a problem.
    can you remove the devices from device manager and then let them install again?
    08-25-2016 08:39 AM
  5. fbrown627's Avatar
    I did that. I

    I spent 2 1/2 hours with Windows tech support. They kept trying to install drivers over and over again and they kept getting error messages. (I don't think the tech person knew what he was doing.) He said I had to talk to the phone manufacturers.

    One phone rep said the drivers in my phone were up to date and suggested I try plugging it into another PC to see if it works. (I only have one so I'm going to try this.)

    I can understand one phone having a problem but two different phones, with two different operating systems?
    08-25-2016 11:46 AM
  6. Chintan Gohel's Avatar
    I did that. I

    I spent 2 1/2 hours with Windows tech support. They kept trying to install drivers over and over again and they kept getting error messages. (I don't think the tech person knew what he was doing.) He said I had to talk to the phone manufacturers.

    One phone rep said the drivers in my phone were up to date and suggested I try plugging it into another PC to see if it works. (I only have one so I'm going to try this.)

    I can understand one phone having a problem but two different phones, with two different operating systems?
    try a different pc and see what happens
    You had already tried a different cable so we can rule that out
    You're plugging them directly into the USB port and not through a USB hub, right?
    08-25-2016 12:20 PM
  7. fbrown627's Avatar
    It's going through a hub but that hub also has an external hard drive and a bluetooth wireless mouse plugged in and they work fine. When I plug my ereader into the hub it works fine. But still, I tried each phone direct but they still didn't work.

    I took the phones to another computer and they were recognized without a problem.

    When the MSFT tech tried to install new drivers, he kept getting an error message. I'm going to try to recreate it tomorrow and will post it. I tired to ask what it was but he rarely listened to me and kept saying "I know what I am doing." No he didn't.

    I got a note from Microsoft that if I wasnt satisfied I should call again and try a different person.
    08-25-2016 06:33 PM
  8. fbrown627's Avatar
    Update. I tried uninstalling the device again. I got error message Code 19. Then I tried reinstalling the drivers and I got error message Code 1.

    Since the phones are fine on other PC's then it has to be a computer problem and not a phone problem.
    08-25-2016 11:52 PM
  9. Chintan Gohel's Avatar
    Update. I tried uninstalling the device again. I got error message Code 19. Then I tried reinstalling the drivers and I got error message Code 1.

    Since the phones are fine on other PC's then it has to be a computer problem and not a phone problem.
    you're using a hub, that is the usually the main problem. Try without the hub and see if they connect
    You can't have too many devices connected on the same hub which transfers to one USB port
    Laura Knotek likes this.
    08-26-2016 09:32 AM

Similar Threads

  1. Deus Ex Go in Windows Store
    By Vincentius Dalton in forum Windows 10
    Replies: 1
    Last Post: 03-08-2017, 06:15 PM
  2. How to get workplace settings in Windows Phone 10?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-16-2016, 06:55 PM
  3. Replies: 1
    Last Post: 08-25-2016, 06:30 AM
  4. Here are the specs for Cube's huge 7-inch Windows 10 Mobile phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-25-2016, 06:30 AM
  5. Windows 10 Anniversary Update Videos get Hang
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-25-2016, 06:27 AM
LINK TO POST COPIED TO CLIPBOARD