1. AnIronButterfly's Avatar
    Every time I click on a URL shortcut I saved, it asks what app I want to use. I click Chrome and tick the box for 'always use this app' and it never, ever sticks. This is driving me crazy.

    Does anyone have any suggestions on how to cure this nuisance? I have tried resetting all default apps, but that didn't work, either...

    It only does it on my PC, not on my Surface 3, oddly enough. (PC is NOT a name brand, I built it myself...)

    Thanks in advance!
    09-13-2016 04:03 PM
  2. pirateNo1's Avatar
    Try uninstalling chrome, reset your cache, then reinstall, it should ask you if you want to set as default browser.
    09-13-2016 04:50 PM
  3. AnIronButterfly's Avatar
    I will give that a try this week...
    09-18-2016 08:54 PM
  4. Chintan Gohel's Avatar
    I will give that a try this week...
    can you check in the settings for default apps?
    And also for any html file - set it to open with chrome by default

    Any update?
    09-25-2016 12:16 PM

Similar Threads

  1. Mydlink lite app won't install
    By bulls96 in forum Windows 10 Mobile
    Replies: 37
    Last Post: 01-26-2017, 07:21 AM
  2. Hp elite x3 not charging trough nokia cr-201
    By elrohlik in forum HP Elite x3
    Replies: 7
    Last Post: 10-03-2016, 10:12 AM
  3. Not able to access apps or even settings.
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-25-2016, 02:48 PM
  4. Images not showing in contacts
    By CaptainLumia in forum Microsoft Lumia 950 XL
    Replies: 10
    Last Post: 09-24-2016, 08:42 AM
  5. Skype for Windows 10 team talks Xbox One app, SMS features and more
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-13-2016, 03:42 PM
LINK TO POST COPIED TO CLIPBOARD