1. Windows Central Question's Avatar
    New to this forum: I have been unsuccessfully trying to resolve this issue through other forums. I am unable to "Get" new apps since Anniversary Update.
    Lumie 640 LTE, Windows 10 Mobile Build 10.0.14393.189
    Can't "Get" new apps from App Store. I get the message: "Try that again. Something happened on our end. Waiting a bit might help."
    Can get updates for installed apps.
    Can download/reinstall "owned apps" that were previously uninstalled.
    Can download/install apps which were installed on my other Lumia 640 LTE on Window Phone 8.1. Any "Owned" app seems to be no problem.
    This is what I have done so far: Soft reset including removing battery. Hard reset and restore. Reset time zone. Turn on/turn off battery saver. Verified that both of my Lumia 640's are listed under "Devices" in my Microsoft Account.
    Hope someone can shed some light on this, and I don't have to wait on a future update to rectify the problem.
    09-30-2016 09:38 AM
  2. Maurizio Troso's Avatar
    New to this forum: I have been unsuccessfully trying to resolve this issue through other forums. I am unable to "Get" new apps since Anniversary Update.
    Lumie 640 LTE, Windows 10 Mobile Build 10.0.14393.189
    Can't "Get" new apps from App Store. I get the message: "Try that again. Something happened on our end. Waiting a bit might help."
    Can get updates for installed apps.
    Can download/reinstall "owned apps" that were previously uninstalled.
    Can download/install apps which were installed on my other Lumia 640 LTE on Window Phone 8.1. Any "Owned" app seems to be no problem.
    This is what I have done so far: Soft reset including removing battery. Hard reset and restore. Reset time zone. Turn on/turn off battery saver. Verified that both of my Lumia 640's are listed under "Devices" in my Microsoft Account.
    Hope someone can shed some light on this, and I don't have to wait on a future update to rectify the problem.

    Check via Edge if your MS account is ok or needs some attention like a check code (go to hotmail.com e.g.)
    "Something happened on our end" means a local server backend iussue (Store doesnt get iussues till now). Try using another wifi or your carrier data
    09-30-2016 11:33 AM
  3. Dbonne's Avatar
    Ok. Per your suggestion I tried another WIFI via my Verizon hotspot. No joy. Tied "Getting" Pandora and got the same failure to "Get" and same message, "Try that again etc". Can there possibly be some issue with having two identical devices, even though the OS is different on each one? On my MS account it does show two Lumia 640's, though I cannot detail the icons to get the properties of each phone and thereby ensure that the serial numbers are different. Would syncing devices play any part in this? And is there a possibility that the settings on the Win 10 phone might be skewed? I thoroughly checked my settings and can't find any problems. As I said, I have no problem getting new apps with the Win 8.1 phone, and then getting those same apps with the Win 10 phone once those apps are "Owned".
    09-30-2016 12:12 PM
  4. Maurizio Troso's Avatar
    Ok. Per your suggestion I tried another WIFI via my Verizon hotspot. No joy. Tied "Getting" Pandora and got the same failure to "Get" and same message, "Try that again etc". Can there possibly be some issue with having two identical devices, even though the OS is different on each one? On my MS account it does show two Lumia 640's, though I cannot detail the icons to get the properties of each phone and thereby ensure that the serial numbers are different. Would syncing devices play any part in this? And is there a possibility that the settings on the Win 10 phone might be skewed? I thoroughly checked my settings and can't find any problems. As I said, I have no problem getting new apps with the Win 8.1 phone, and then getting those same apps with the Win 10 phone once those apps are "Owned".
    The only thing you can't change is your location. SO that's really a local backend iussue. Only ways for fixing that are 1) wait till servers fix it, as usual, about 24 hrs .2) change country ;) That's the meaning of my statement

    Windows 10 uses different store (and servers)
    09-30-2016 01:01 PM
  5. Dbonne's Avatar
    I appreciate your reply. Just want to update the situation to see if it flags anything. Since my last reply, I installed Pandora on my Win 8.1 phone and then downloaded and installed the "Owned" Pandora app flawlessly to my Win 10 phone. I had previously tried to get Pandora this morning on the Win 10 phone with the same failure and message. Also two days ago, following other suggestions on the web, I changed the location of the phone to Virgin Islands. So location doesn't seem to make a difference either. What I can't understand is why I can download and install an "owned" app but not a new app. I would welcome an explanation for this if you have one.
    Chintan Gohel likes this.
    09-30-2016 06:29 PM
  6. jijesh babu's Avatar
    I can't find colour profile settings in extras, after the update. Please help.. I am using lumia 540
    09-30-2016 07:14 PM
  7. Chintan Gohel's Avatar
    I appreciate your reply. Just want to update the situation to see if it flags anything. Since my last reply, I installed Pandora on my Win 8.1 phone and then downloaded and installed the "Owned" Pandora app flawlessly to my Win 10 phone. I had previously tried to get Pandora this morning on the Win 10 phone with the same failure and message. Also two days ago, following other suggestions on the web, I changed the location of the phone to Virgin Islands. So location doesn't seem to make a difference either. What I can't understand is why I can download and install an "owned" app but not a new app. I would welcome an explanation for this if you have one.
    Can you sign out of store? And then sign back in?
    And try the new 14393.221 update
    10-01-2016 09:03 AM
  8. Chintan Gohel's Avatar
    I can't find colour profile settings in extras, after the update. Please help.. I am using lumia 540
    I also have a 540 and the settings are there in settings > extra > display
    jijesh babu likes this.
    10-01-2016 09:04 AM
  9. Dbonne's Avatar
    I tried something this morning (grabbing at straws) from a question that that. You aked if I was able to sign in and sign out from the App Store. I wasn't sure what you meant so I found where there was a sign out option when I tapped on my account from the App Store home logo. I signed out and then attempted to install a third party calculator app. It installed without a problem. I then signed back in in the Store app and again attempted to "Get" a third party app. I got the familiar "Try that again........" message.

    So it seems that when I am signed in to the store I cannot "Get" a new app and when I am signed out I can.

    Does this make sense to anyone? As I said, this all started after the Anniversary Update. I can live with having to sign out to get a new app and then sign back in, but it shouldn't work this way. Any idea on what's going on. From reading some other posts in this and other forums it seems that this issue is not limited to Mobile.
    10-02-2016 07:23 AM
  10. Chintan Gohel's Avatar
    I tried something this morning (grabbing at straws) from a question that that. You aked if I was able to sign in and sign out from the App Store. I wasn't sure what you meant so I found where there was a sign out option when I tapped on my account from the App Store home logo. I signed out and then attempted to install a third party calculator app. It installed without a problem. I then signed back in in the Store app and again attempted to "Get" a third party app. I got the familiar "Try that again........" message.

    So it seems that when I am signed in to the store I cannot "Get" a new app and when I am signed out I can.

    Does this make sense to anyone? As I said, this all started after the Anniversary Update. I can live with having to sign out to get a new app and then sign back in, but it shouldn't work this way. Any idea on what's going on. From reading some other posts in this and other forums it seems that this issue is not limited to Mobile.
    maybe it's related to the way MS is rolling out the outlook.com upgrade
    10-02-2016 08:06 AM
  11. jijesh babu's Avatar
    I also have a 540 and the settings are there in settings > extra > display
    10-02-2016 09:59 AM
  12. jijesh babu's Avatar
    I had but after the anniversary update. I can't find it.
    10-02-2016 10:00 AM
  13. DennisvdG's Avatar
    I'm experiencing the same problem. Very annoying to not be able to update my stuff...
    10-08-2016 06:57 PM
  14. holdum333's Avatar
    Hi ! I'm not a user of the Apps store,but I'm wondering if this has any thing to do with these issues. Has anyone tried this? Makes sense to me.
    Has anyone here tried this fix. Sorry if I'm out in left field on this topic. This is a fix from MS, so I can't see any harm in giving it a look!
    https://solutions.diagnostics.suppor...-337fca72c533#
    10-08-2016 07:46 PM
  15. DennisvdG's Avatar
    That only applies to desktop, but thanks for trying!
    10-09-2016 09:43 AM

Similar Threads

  1. Anyone buy from eBay? Specifically from sellers in Hong Kong?
    By IIDXholic in forum Microsoft Lumia 950
    Replies: 15
    Last Post: 10-17-2016, 01:23 PM
  2. Windows Update fails but no failures are reported in Windows Update History
    By Windows Central Question in forum Ask a Question
    Replies: 8
    Last Post: 10-02-2016, 01:55 PM
  3. Today is the deadline for age ratings to be added to current Windows Store apps
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 10-01-2016, 04:44 PM
  4. Maps for Windows 10 updated for production ring with dark theme and traffic hub
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-30-2016, 09:00 AM
  5. HTC Viveport online VR app store launches worldwide
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-30-2016, 08:11 AM
LINK TO POST COPIED TO CLIPBOARD