1. Windows Central Question's Avatar
    Hey all, I encountered this problem with my surface pro 3 where I installed a clean Windows 10 from the microsoft website, and from then the system does not boot past the "surface" boot logo.

    I have tried all ways possible from my standpoint, going to BIOS and disabling TPM and secure boot, keying in my Bitlocker recovery key, and the page just doesn't go past the surface boot logo page.

    Please help!
    10-02-2016 12:26 AM
  2. Chintan Gohel's Avatar
    Hey all, I encountered this problem with my surface pro 3 where I installed a clean Windows 10 from the microsoft website, and from then the system does not boot past the "surface" boot logo.

    I have tried all ways possible from my standpoint, going to BIOS and disabling TPM and secure boot, keying in my Bitlocker recovery key, and the page just doesn't go past the surface boot logo page.

    Please help!
    what about starting in safe mode? Is that possible?

    If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Windows Central.
    10-02-2016 02:47 AM

Similar Threads

  1. after windows 10 anniversary update my wi-fi and bluetooth disappeared
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 10-13-2016, 10:39 AM
  2. Replies: 4
    Last Post: 10-07-2016, 09:54 AM
  3. Replies: 2
    Last Post: 10-02-2016, 10:44 AM
  4. How do I sync my jawbone with my windows 10 computer?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-02-2016, 02:43 AM
  5. Please help me in fixing this problem
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-02-2016, 01:54 AM
LINK TO POST COPIED TO CLIPBOARD