1. Windows Central Question's Avatar
    I have gone through MYTURBOPC and it is now asking for Licence Key; I press the button saying "Get Licence Key" which opens Microsoft Edge but nothing is displayed. I seem to be going round in circles. Please advise.
    10-07-2016 07:41 AM
  2. abhishek singh21's Avatar
    Hi and welcome to windows central forums :)

    have you tried restarting your pc? or you could kill edge ( under task manager of course)and set your google chrome or firefox or opera as the default web browser. i have faced a similar situation where edge neither loads the page or closes , even after killing its process under task manager.

    If you need additional help or want to reply to this thread , click on the smiley :) to learn how to join our forums.
    holdum333 likes this.
    10-07-2016 11:34 AM
  3. holdum333's Avatar
    Hi ! Edge has to many bugs for me. It is getting better however! Firefox is my default!
    10-07-2016 11:40 AM

Similar Threads

  1. Microsoft 640XL SD Card data grows up suddenly and displays Low Storage sense
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-08-2016, 10:27 AM
  2. How to open devtools to check the DOM in Microsoft Edge when in full screen mode?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-07-2016, 05:44 AM
  3. why lumia 1320 not update in windows 10 when i alredy install windows insider
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-07-2016, 05:04 AM
  4. Yahoo mail not opening in my windows 535 mobile
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-07-2016, 02:36 AM
  5. app are not good?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-07-2016, 01:19 AM
LINK TO POST COPIED TO CLIPBOARD