1. Windows Central Question's Avatar
    No idea what has caused this. All battery apps give the same wrong estimate of time remaining. Over 6 days when it should be something like 1 Day xHours. The battery discharge rate seems to behave as normal percentage wise.

    I've just updated it to Windows 10.0.14393.321 - still the same.
    I've done a soft reset (power + volume down button) - still the same.

    What else can I do? Is the OS dumb? Is the battery screwed?

    The phone is under a month old.

    p.s the battery gets quite hot under any semi intensive load but this seems to be a very common trait of the phone.
    10-12-2016 06:43 AM
  2. Summer_Moon's Avatar
    No idea what has caused this. All battery apps give the same wrong estimate of time remaining. Over 6 days when it should be something like 1 Day xHours. The battery discharge rate seems to behave as normal percentage wise.

    I've just updated it to Windows 10.0.14393.321 - still the same.
    I've done a soft reset (power + volume down button) - still the same.

    What else can I do? Is the OS dumb? Is the battery screwed?

    The phone is under a month old.

    p.s the battery gets quite hot under any semi intensive load but this seems to be a very common trait of the phone.
    Try letting it drain all the way to 0% (or wherever it shuts itself down at), then plug it in and let it charge to 100%. Might need to do this cycle 2-3 times. Check your battery estimate afterwards and see if it's adjusting to what the real estimate is. If I remember correctly it takes into account past timeframes for how long the battery lasted, so could have been thrown off based on how often you charge
    10-12-2016 08:14 AM

Similar Threads

  1. Replies: 14
    Last Post: 02-23-2017, 07:13 AM
  2. Replies: 1
    Last Post: 10-12-2016, 07:22 AM
  3. Lumia 640 LTE data overconsumption
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 10-12-2016, 06:31 AM
  4. Why is my Lumia 1520 back lights not working
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-12-2016, 05:27 AM
  5. Video recording with no or less sound (Lumia 930)
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-12-2016, 04:30 AM
LINK TO POST COPIED TO CLIPBOARD