1. Windows Central Question's Avatar
    I had my lumia 925 from UAE, and it was working fine for two years. I went to Poland and I charged my phone on Polish plug charger. First it worked normally but on the second day it was lagging when I was using it, and I soft reset it for couple times. But it was still lagging until it turned off. and a black screen appeared with some text. I dont remember exactly the content of the text, but it was something about booting. And now when I plug it on usb charger, the windows icon blinks for sec and then it turns off. And the phone doesnt start.

    ANY IDEA HOW TO FIX THIS.
    11-09-2016 11:10 AM

Similar Threads

  1. How do I get notifications in outlook.com in Windows 10 on my phone?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-12-2016, 02:38 PM
  2. How paitent should I be for my next phone?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-09-2016, 12:02 PM
  3. Why did all my photos get deleted when I was removing only some of them?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 11-09-2016, 10:11 AM
  4. i cant share my files with other phones with my bluetooth on my nokia lumia 1520
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 11-09-2016, 10:06 AM
  5. My 950 doesn't like the display dock
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 11-09-2016, 08:05 AM
LINK TO POST COPIED TO CLIPBOARD