The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. TheSkum668's Avatar
    Lumia 640LTE
    Windows Phone 8.1 Update 2

    I bought myself a new 32gb sd card because the current 4gb sd card was just not cutting it. (It was all I had at the time...)

    So I have formatted the card in the phone, set all music/photos/apps/etc to go to the sd card.

    I put music on the sd card (copy via cable connected to Win7 desktop) and wait a bit for it to show up in music app (like it usually does)

    I open up the music app (which I have never really had too much trouble with) and some of the music I copied is there.

    Then later on I check and there is nothing there. I reconnect to the pc via cable, browse the sd card and all the music is there where I put it, but the music app does not see it.

    Try again, this time I happen to be browsing music inside the music app and albums that are there are disappearing in as I'm viewing them.

    What is going on here?

    Why does the stuff disappear?
    Why does the stuff disappear AS I AM WORKING WITH IT?

    Is there a way to purge or reset the music library so that it works as before?

    I've been fighting with this since yesterday and it's driving me mad.

    Help!
    Last edited by TheSkum668; 03-11-2017 at 05:45 AM.
    03-11-2017 05:03 AM
  2. Ryujingt3's Avatar
    If it disappears when you are working with it it is a cable/USB port issue. Try a different cable/USB port and see if that helps.
    03-12-2017 06:18 AM
  3. TheSkum668's Avatar
    I have inadvertently used 2 different cables on 2 different pc's.
    The problem is that if I am browsing the music library on the phone itself (ie from within the Music app), some music will show, if I close Music and re-open it, some will have disappeared.
    I have had it that I was browsing a folder and when I moved back up to the 'root' level the folder I had just been browsing was missing.
    I have also watched as folders disappeared while I was looking at the folder list in the library.
    Earlier today I copied some stuff to the phone. An hour later it was still there.
    This evening I checked back and some was there. Less than 5 minutes later, it was missing.
    I plugged the phone in to my pc and all of the music is present in the Music folder on the SD Card, but for some stupid reason, the music app can't see it - all it gives me is the 'it's lonely in here' message, and this is for all of the options in the 'showing' field.
    03-12-2017 03:37 PM
  4. T Moore's Avatar
    Did you copy photos over? Is the card working for them?
    Where did you copy the music to?
    Is it a name brand card.
    03-13-2017 12:01 AM
  5. Chintan Gohel's Avatar
    Lumia 640LTE
    Windows Phone 8.1 Update 2

    I bought myself a new 32gb sd card because the current 4gb sd card was just not cutting it. (It was all I had at the time...)

    So I have formatted the card in the phone, set all music/photos/apps/etc to go to the sd card.

    I put music on the sd card (copy via cable connected to Win7 desktop) and wait a bit for it to show up in music app (like it usually does)

    I open up the music app (which I have never really had too much trouble with) and some of the music I copied is there.

    Then later on I check and there is nothing there. I reconnect to the pc via cable, browse the sd card and all the music is there where I put it, but the music app does not see it.

    Try again, this time I happen to be browsing music inside the music app and albums that are there are disappearing in as I'm viewing them.

    What is going on here?

    Why does the stuff disappear?
    Why does the stuff disappear AS I AM WORKING WITH IT?

    Is there a way to purge or reset the music library so that it works as before?

    I've been fighting with this since yesterday and it's driving me mad.

    Help!

    I'm suspecting that the card is faulty - just to be sure, can you try your old card or another one and see if the same behaviour is repeated?
    03-13-2017 03:27 AM
  6. Starboy21's Avatar
    Try downloading music locker it scans for music in the memory n yess its quite gud..hope it helps
    03-13-2017 03:46 AM
  7. TheSkum668's Avatar
    The card seems fine (it's an Adata) - the music is there when I plug the phone into the pc, and also if I browse using the Files app. (or Metro File Manager).
    Using a different free music player to test with and it works fine - just the ads :(
    Copied photos and they also don't show in the Photos app - copied photos and music to the default photos and music folders on the sd card that wp creates.
    I suspect that it's just badly written apps to blame as as different music player seems to be quite happy.
    It's just annoying because 1) it used to work just fine, 2) free apps are full of ads and 3) I now have to pay to get a working, ad-free app to do the simple job that this (as part of the OS) should be able to do but inexplicably can't.
    03-13-2017 10:03 AM
  8. Starboy21's Avatar
    How about removing n inserting the sd card again n restarting ur phone playing the music thru files app or a soft reset
    03-13-2017 10:21 AM
  9. Jaripi's Avatar
    Missing tags of songs might also cause that (some music players can not find the such songs). I am using Tag & Rename program to make tags for songs.
    03-13-2017 02:02 PM
  10. T Moore's Avatar
    Get a name brand card.
    UHS-1 class 10
    03-13-2017 03:56 PM
  11. TheSkum668's Avatar
    Phone has been restarted several times, card has been removed, reinserted, formatted (in the phone), all songs are fully tagged and named - a lot are the same songs I had on the old card...
    Playing through Files app only plays one song at a time (no playlist) so while that does work, it's not really a solution.
    Thanks for all the input so far though.
    A bit of a head-scratcher this...
    @Chintan Gohel - I did put the old card back in and it's does the same thing. Also, the old card still has everything on it - confirmed by checking it on a pc and in the files app on the phone, but still 'it's lonely in here...'
    03-13-2017 04:15 PM
  12. Chintan Gohel's Avatar
    Phone has been restarted several times, card has been removed, reinserted, formatted (in the phone), all songs are fully tagged and named - a lot are the same songs I had on the old card...
    Playing through Files app only plays one song at a time (no playlist) so while that does work, it's not really a solution.
    Thanks for all the input so far though.
    A bit of a head-scratcher this...
    @Chintan Gohel - I did put the old card back in and it's does the same thing. Also, the old card still has everything on it - confirmed by checking it on a pc and in the files app on the phone, but still 'it's lonely in here...'
    then your os has somehow become corrupted - which I've never heard of happening for windows phone 8.1 but there's always a first time

    If you're willing, can you try resetting your phone, preferably using windows device recovery tool?

    You could also upgrade your phone to windows 10 mobile
    03-14-2017 02:28 AM
  13. digitaldd's Avatar
    I don't believe the Lumia 640LTE supports fast sdcards so spending more for a class 10 is pointless.

    For what its worth I had similar issues with photos and music that I copied over to the phone using File Explorer, they often would not be found when opening the Music app (especially Groove on WP10) or trying to find local photos with the photos app. However if I copied the files over using the Microsoft Phone Companion application they were discovered once I opened the associated app on the phone. However File explorer always seems to work when connecting to a Windows 7 system (for me at least).
    Chintan Gohel likes this.
    03-14-2017 08:12 AM
  14. TheSkum668's Avatar
    I eventually did factory reset the phone, everything seems to be much better now...
    Thanks for all the input anyway...
    04-17-2017 04:46 PM

Similar Threads

  1. Replies: 4
    Last Post: 03-18-2017, 11:23 PM
  2. Which is the best podcast app in windows 10 mobile?
    By shparvez001 in forum Ask a Question
    Replies: 2
    Last Post: 03-12-2017, 06:17 AM
  3. Back in my Lumia!
    By Gustavo Sanchez in forum Nokia Lumia 925
    Replies: 3
    Last Post: 03-10-2017, 11:00 PM
  4. how can i sign in to my surface pro 3 if i forgot my password?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-10-2017, 07:11 PM
  5. Shazam pulls the plug on its Windows apps for PC and Mobile
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-10-2017, 05:13 PM
LINK TO POST COPIED TO CLIPBOARD