The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Henry Linc's Avatar
    Why Windows Central Apps keep freezing all the time? every 5-10 second the app become unresponsive... There this one notification, said that someone replied on my comment, and when I tap on it, it open the Windows Central, directly to the article that the person reply my comment, and it stuck there with blank black page. I'm seriously really frustrating with this Windows Central App... and I can't even find what the person just replied. If I post something on forum, like this one... I had to scroll down to find my question too see if someone has answered it yet. Why there are no notification center like YouTube or Facebook... I think I just gonna use this app for reading news, but still makes me frustrating with the apps keeps freezing every 5-10 seconds. I already report about this at Feedback Hub like a few months ago, but useless... and UI, it may be similar with the one I found on Groove Music. But I've been using this app for like 3-4 months, but still until now I'm trying to understand the UI. I don't know why.
    06-06-2017 12:53 PM
  2. Josiah23's Avatar
    What device are you using and does a reboot and/or reinstalling the Windows Central app fix any of the problems?

    I have noticed that the notifications for the WC app has been iffy for a while, some say it works and others can't get it to work. Try reinstalling the app and see if anything works out for you. :-)

    I'll pass this on to the others to step in and help you out a bit more, since you've been having trouble with the app for a while now.
    Last edited by Josiah23; 06-06-2017 at 01:23 PM.
    pkcable likes this.
    06-06-2017 01:01 PM
  3. pkcable's Avatar
    I'm with Josiah, we need to know what phone you are using in order to help. I'm not 100% sure if there is an issue with the app or if it's your phone AND the app, AND we can solve it. Have you tried restarting your phone? You are not talking Android right? IF you are then clearing the app cache under settings might help.
    Josiah23 likes this.
    06-06-2017 01:13 PM
  4. Henry Linc's Avatar
    I'm using Lumia 950 and Acer Aspire R7. both Windows Central apps on them have same problem. I already tried reinstall the apps but still same. Doesn't make any change.
    06-06-2017 01:15 PM
  5. Henry Linc's Avatar
    This section also has problem. the refresh button sometimes doesn't work. And when I comment to one of the forum post, it won't display my comment. I had to go to other post, and go back the post that I just comment to view it. But sometimes that doesn't work. I had to close the app and open it again.
    06-06-2017 01:18 PM
  6. Josiah23's Avatar
    This section also has problem. the refresh button sometimes doesn't work. And when I comment to one of the forum post, it won't display my comment. I had to go to other post, and go back the post that I just comment to view it. But sometimes that doesn't work. I had to close the app and open it again.
    Now that's a bit odd if you ask me...

    It's almost as if your devices aren't working with the app the way it's suppose to work.

    Others apps (to my knowledge) has been working just fine on their L 950's, so I'm not understanding why it wouldn't work with yours.

    I would say try using the browser version (Chrome, Edge, FF, etc...) of the forums on one of your devices and see if you have any problems there.
    06-06-2017 01:32 PM
  7. Henry Linc's Avatar
    Originally posted by pkcable
    I'm with Josiah, we need to know what phone you are using in order to help. I'm not 100% sure if there is an issue with the app or if it's your phone AND the app, AND we can solve it. Have you tried restarting your phone? You are not talking Android right? IF you are then clearing the app cache under settings might help.
    so many soft reset, I even had to hard reset once. but still same.
    06-06-2017 01:39 PM
  8. Henry Linc's Avatar
    Originally posted by Josiah23
    Originally Posted by Henry Linc
    This section also has problem. the refresh button sometimes doesn't work. And when I comment to one of the forum post, it won't display my comment. I had to go to other post, and go back the post that I just comment to view it. But sometimes that doesn't work. I had to close the app and open it again.
    Now that's a bit odd if you ask me...

    It's almost as if your devices aren't working with the app the way it's suppose to work.

    Others apps (to my knowledge) has been working just fine on their L 950's, so I'm not understanding why it wouldn't work with yours.

    I would say try using the browser version (Chrome, Edge, FF, etc...) of the forums on one of your devices and see if you have any problems there.
    Of course the web version are better... But I don't really like it because I often visit the forum section... And of course I don't want to open edge just to visit the Windows Central in my phone (I can do that on my notebook, but not on my phone.)
    06-06-2017 02:09 PM
  9. pkcable's Avatar
    Probably a bug with the app, hopefully they are working on a fix. :)
    Josiah23 likes this.
    06-08-2017 02:21 PM

Similar Threads

  1. hi i had a windows 7 pro PC i hadn't activated it.
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-06-2017, 11:25 AM
  2. Kaspersky files antitrust complaint against Microsoft in Europe over Windows Defender
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-06-2017, 11:10 AM
  3. Hands on with Windows 10 build 16212 for PC (video)
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-06-2017, 11:10 AM
  4. Logicos is a challenging Windows 10 puzzle game that can drive you batty
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-06-2017, 09:10 AM
  5. Replies: 0
    Last Post: 06-06-2017, 08:57 AM
LINK TO POST COPIED TO CLIPBOARD