1. Eric Fate's Avatar
    My device is Lumia 635.
    OS is Windows 8 and can't be upgraded to Windows 10.

    Yesterday I found it couldn't connect to the wifi hotspot created by my desktop. Restarting did not work. But it could connect to the wifi in the library.

    So I thought it was the problem with the wifi hotspot on my desktop. To my surprise, my friend's phone could connect to it with no problem.

    I reset my phone, and it was fixed. Then I believed it's a problem with my phone, not the wifi hotspot on my desktop. I could connect to my wifi hotspot for a while, until I have my phone connected to the wifi in the library and came back to my room.

    After I came back to my room, my phone failed to connect to my own wifi hotspot again. I've tried many times, it keeps failing. I've also tried restarting, and it never works.

    I'm not quite sure whether it's relevant to the wifi in the library. But it seems that my phone fails to connect to the wifi hotspot in my room ONLY after I came back from the library...

    PS: there is no Static IP option on my phone.
    10-15-2017 08:32 AM
  2. TechFreak1's Avatar
    My device is Lumia 635.
    OS is Windows 8 and can't be upgraded to Windows 10.

    Yesterday I found it couldn't connect to the wifi hotspot created by my desktop. Restarting did not work. But it could connect to the wifi in the library.

    So I thought it was the problem with the wifi hotspot on my desktop. To my surprise, my friend's phone could connect to it with no problem.

    I reset my phone, and it was fixed. Then I believed it's a problem with my phone, not the wifi hotspot on my desktop. I could connect to my wifi hotspot for a while, until I have my phone connected to the wifi in the library and came back to my room.

    After I came back to my room, my phone failed to connect to my own wifi hotspot again. I've tried many times, it keeps failing. I've also tried restarting, and it never works.

    I'm not quite sure whether it's relevant to the wifi in the library. But it seems that my phone fails to connect to the wifi hotspot in my room ONLY after I came back from the library...

    PS: there is no Static IP option on my phone.
    Sadly, Microsoft in their "infinite" wisdom decided that enabling users to set a Static IP would be down to the OEM's through an optional edit in specific .xml file. I can't recall which from the top of my head, which is why some phone models have that ability to set a static IP and majority do not.

    It's one the key things that irks me so much about WM10 and Wp 8.x.

    The only way around this is add the MAC address of the phone to the hotspot and associate a static IP address to it.

    I have issues with my L930 connecting to one router and not the others, so the only way I could resolve that was to add the mac address and specific IP address, then remove it from the allowed MAC address list, it's counter intuitive but that was the only way I got it to work with my network. If Microsoft allowed users to set a static IP address, we wouldn't have to resort roundabout solutions.

    Other than going through the risky interop unlock process to jail break WM10, there is not much you can do I'm afraid other than get a repeater or new phone which also may have the same issue as you currently have. Or wait for cumulative update for WM10 that may fix your issue, although that is highly unlikely given the current situation with WM10.
    10-15-2017 09:38 AM

Similar Threads

  1. Get a one-year subscription to Linux Academy for just $149!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 2
    Last Post: 11-23-2017, 02:34 AM
  2. Replies: 9
    Last Post: 11-19-2017, 01:19 AM
  3. Delay when switching audio from speakers to headphones
    By rwakeham27 in forum Microsoft Surface Pro (2017)
    Replies: 1
    Last Post: 10-16-2017, 05:33 AM
  4. I can't reinstall Store app!
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 10-15-2017, 07:26 AM
  5. Replies: 1
    Last Post: 10-14-2017, 09:55 AM
LINK TO POST COPIED TO CLIPBOARD