1. Windows Central Question's Avatar
    It's an Asus zenbook. I tried to update the security for windows 10 a couple weeks ago when I received notification of it. But every time I would restart to complete installation, the installation would not complete and I would receive another notification for the same security update. It was really irritating and my computer would reboot at inconvenient times. So to avoid getting those repeated notifications and constant failed security update attempts, I attempted to restore a previous version of windows 10. When I restarted upon being prompted, to complete the reversion, I now get the following loop upon powering up:

    The Asus logo appears, then the sort of generic loading circle below it for a couple seconds. Then black screen for a couple seconds. Then a nano second flash of a box in top left quadrant of screen. Then a message flashes briefly on bottom of screen saying "restoring previous version of windows 10" or something like that (it's too brief to be 100%). Then back to Asus logo and goes through same series.

    I cannot access safe mode to reinstall drivers or do anything.

    I would be super grateful for solution.

    Thank you
    01-04-2018 12:21 AM
  2. KilledByWindows10's Avatar
    Hi, I gave the exact same issue .. were you able to fix this by any chance?


    It's an Asus zenbook. I tried to update the security for windows 10 a couple weeks ago when I received notification of it. But every time I would restart to complete installation, the installation would not complete and I would receive another notification for the same security update. It was really irritating and my computer would reboot at inconvenient times. So to avoid getting those repeated notifications and constant failed security update attempts, I attempted to restore a previous version of windows 10. When I restarted upon being prompted, to complete the reversion, I now get the following loop upon powering up:

    The Asus logo appears, then the sort of generic loading circle below it for a couple seconds. Then black screen for a couple seconds. Then a nano second flash of a box in top left quadrant of screen. Then a message flashes briefly on bottom of screen saying "restoring previous version of windows 10" or something like that (it's too brief to be 100%). Then back to Asus logo and goes through same series.

    I cannot access safe mode to reinstall drivers or do anything.

    I would be super grateful for solution.

    Thank you
    01-27-2018 10:07 AM

Similar Threads

  1. Why can't I set up Whatsapp?
    By Ronald Sutandi in forum Windows 10 Mobile
    Replies: 23
    Last Post: 01-28-2018, 03:19 AM
  2. Replies: 0
    Last Post: 01-03-2018, 07:50 PM
  3. Replies: 0
    Last Post: 01-03-2018, 06:46 PM
  4. Microsoft's Cortana loses song ID ability in Windows as Groove ends too
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-03-2018, 05:30 PM
  5. Intel responds to reports of processor security flaw, says other manufacturers are affected
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-03-2018, 04:50 PM
LINK TO POST COPIED TO CLIPBOARD