1. Windows Central Question's Avatar
    I Have nokia lumia 735 right now, and i had 640, and 820 before. I have often experienced poor internet connection from a network (not a wi/fi). Sometimes it would even show it as no Service until i restart my phone then goes back to normal.

    But the main issue is just inconsistent internet. When listening to Spotify, or just browsing. Spotify doesn't even seem to work in offline mode.

    Is this something common with the poor internet reception or something?

    I have tried restarting, soft and hard resenting it. And even bought a new phone few months ago which is current 735. Had that issue before on 640 which i had for about 2 years.

    Runing latest updates of the phones and apps.

    As far as error message it's usually in the top left corner of the screen where reception is. It's the little arrow that appears next to the signal strength (which i assume it tries to recieve/send signal) and it's not going well.

    So is this something common with windows phones in general?

    Or should i try changing operators i don't know if that contributes to anything.
    02-06-2018 04:56 AM
  2. Chintan Gohel's Avatar
    Try to get a new SIM card - the SIM card is usually the issue

    Or try a different operator is you're able to do that

    Ask your operator if you have the right connection settings too
    02-06-2018 05:09 AM
  3. Chintan Gohel's Avatar
    I Have nokia lumia 735 right now, and i had 640, and 820 before. I have often experienced poor internet connection from a network (not a wi/fi). Sometimes it would even show it as no Service until i restart my phone then goes back to normal.

    But the main issue is just inconsistent internet. When listening to Spotify, or just browsing. Spotify doesn't even seem to work in offline mode.

    Is this something common with the poor internet reception or something?

    I have tried restarting, soft and hard resenting it. And even bought a new phone few months ago which is current 735. Had that issue before on 640 which i had for about 2 years.

    Runing latest updates of the phones and apps.

    As far as error message it's usually in the top left corner of the screen where reception is. It's the little arrow that appears next to the signal strength (which i assume it tries to recieve/send signal) and it's not going well.

    So is this something common with windows phones in general?

    Or should i try changing operators i don't know if that contributes to anything.
    If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Windows Central.
    02-06-2018 05:10 AM

Similar Threads

  1. why does my lumia 650 not connect to internet???
    By Netti12463 in forum Microsoft Lumia 650
    Replies: 6
    Last Post: 02-05-2018, 05:05 PM
  2. Replies: 1
    Last Post: 01-29-2018, 09:20 PM
  3. Replies: 6
    Last Post: 01-12-2018, 10:24 AM
  4. Grab a two-year subscription to Private Internet Access VPN for $34
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-02-2018, 10:40 AM
  5. Keep your internet browsing encrypted with VPNSecure, now 91% off
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-22-2017, 10:40 AM
LINK TO POST COPIED TO CLIPBOARD