1. Noob Cydroid's Avatar
    Hope someone can help me out with this. And thank you in advance for at least reading through all of this.

    At work I'm sometimes asked to test, trouble shoot, install, or add on to an existing WiFi network. Some of the testing I'm required to do is to test the performance of the WiFi network/equipment on both the 2.4ghz and 5ghz bands individually.

    Not sure how long exactly this has been happening, but I noticed it probably a couple months ago. My SP3's WiFi has been inconsistent and slow when using the 2.4ghz radio. When at its worst, running a continuous ping test can result in bad ping times ranging as high as over a 100ms when pinging even the Default Gateway. Speed Tests may also come in slow on just the download, just the upload, or sometimes both. How bad the issue is can vary, it's actually quite inconsistent. Inconsistent enough that after first noticing it, the problem SEEMED to be gone for a while and I thought it was just a fluke or Windows was just doing something in the background that particular time. But I'm noticing it again recently quite a bit.

    Everything is always fine when using the 5ghz radio.

    I've confirmed that it's something with my SP3 and not the WiFi/network. My phone gets good Speed Test results all the time. When running the same tests on my workmate's laptop, his laptop hasn't had issues when my SP3 does. His pings and speed tests results are good. I've checked for WiFi interference as well and found there was no other WiFi sources on the same or adjacent channels nearby.

    So far I've also done some typical things to trouble shoot. Rebooted my system. Rebooted WAP and switches. At home, I've also rebooted my WiFi router. I've also tried uninstall/reinstall WiFi Adapter drivers.

    Has anyone else had something similar or could chime in on what I could be dealing with?

    Thanks!

    FWIW: A while back someone pointed out to me that Windows 10 has been doing some sort of aggressive power management with the WiFi. If you don't have the charger plugged in, WiFi performance was reduced. I saw what he was talking about by running a continuous ping test. While my SP3 power was unplugged, ping times were noticeably higher. As soon as I plugged in the charger, ping times dropped dramatically. He showed me a registry edit that got rid of that. I can't remember what it was, but also wondering if maybe that is starting to come back and haunt me in some way.

    Some info on my device:
    Surface Pro 3 i7 8GB RAM
    Windows 10 1809 Build 17763.437

    WiFi Adapter:
    Marvell AVASTAR Wireless-AC Network Controller
    Driver ver. 15.68.9125.57
    05-03-2019 12:26 AM
  2. ven07's Avatar
    I think you've gone through most of the troubleshooting steps lol. Did you try manually setting the IP? How many devices have you got on the same channel? perhaps try switching channels on the router?
    pkcable likes this.
    05-03-2019 08:42 AM
  3. Ryujingt3's Avatar
    Are you sure it's not your ISP?
    pkcable likes this.
    05-03-2019 09:52 AM
  4. Noob Cydroid's Avatar
    Didn't try setting a static IP. I'm sure it's not the ISP. Everything is awesome when using my 5ghz and my workmate's test laptop doesn't have any issues when he's on the 2.4ghz band. I've even confirmed we are connected to the same WAP and that it's just either both or just one of us connected to it as well. Happens even if I'm sitting right on top of the WAP...

    Software wise, I'm thinking of trying to factory default my SP3, but need to find the time. Other than that, I might be looking at signs my WiFi NIC itself is starting to go bad... :(

    Just in case, anyone know of a really good USB WiFi adapter? I'll need to be able to set it to only use specifically 2.4ghz or 5ghz when needed (another workmate's WiFi NIC doesn't have that setting in the driver properties forcing him to have disable individual radios on APs when he tests). And it'll need to have good reach and consistency as well.
    05-03-2019 04:52 PM
  5. Ryujingt3's Avatar
    See if any of these USB wifi adapters meet your needs.

    https://www.pcgamer.com/uk/best-usb-wi-fi-adapter/
    ven07 and sushantch_ht like this.
    05-05-2019 09:16 AM
  6. Noob Cydroid's Avatar
    Thanks for the link! I'm gonna get my research started a USB WiFi.
    05-06-2019 07:22 PM
  7. Ryujingt3's Avatar
    Thanks for the link! I'm gonna get my research started a USB WiFi.
    Happy I could be of some use - good luck!
    05-07-2019 08:36 AM

Similar Threads

  1. The display mode is grey-ed out and I cant choose the temperature option!
    By Windows Central Question in forum Ask a Question
    Replies: 5
    Last Post: 05-29-2019, 08:50 AM
  2. how many people still use Windows Lumia 730 in April, 2019 ? and How it work ?
    By Windows Central Question in forum Nokia Lumia 730 & 735
    Replies: 4
    Last Post: 05-05-2019, 09:04 AM
  3. which website is best for vivo mobile back covers?
    By styleken in forum Ask a Question
    Replies: 2
    Last Post: 05-03-2019, 09:55 AM
  4. SteelSeries Arctis 9X vs. Turtle Beach Elite Atlas: Which is right for you?
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-02-2019, 05:11 AM
  5. Samsung's 1TB T5 portable solid state drive is down to $170 today
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-01-2019, 07:20 PM
LINK TO POST COPIED TO CLIPBOARD