1. oxfordia's Avatar
    Running Windows 10 Pro 1903 number 18363

    I followed steps from Windows Central post entitled "how-move-default-user-folders-new-drive-windows-10" (and works perfectly...for a time).
    HOWEVER
    "IF" Windows does a "Startup" chkdsk, it makes drive D:\ "not accessible".

    There is an option to "skip disk checking for 8 second(s), but if I don't skip the chkdsk, it goes through "Fixing (D:) Stage 2 100% (724 of 724); Total: 70% ETA: 0:00:01.."...then..."Fixing (D:) Stage 2 100% (43 of 43); Total: 0% ETA: 999:00:0.."...then..."Fixing (D:) Stage 3 100% (0 of 0); Total: 99% ETA: 0:00:00.."...then..."Scanning and repairing drive (D:): 100% complete...then "D:\D User\Desktop is unavailable...." (OR by double-clicking on it in Windows Explorer I get the error message "D:\ is not accessible. Access is denied")

    Now, I CAN get the greyed out NTFS drive to show back up by right-clicking and enabling the "Authenticated Users" Security protocol again, BUT (although it show data on the drive in Windows Explorer) if I double-click on the drive it show empty.

    SEVERAL QUESTIONS:
    1. How do I PREVENT chkdsk from doing this again (short of bypassing the check during first 8 seconds of startup) OR MORE PROPERLY...How do I get chkdsk to recognize that this is a PROPER file system (Volume Information, etc.) and that I moved the "Default User Folders"?
    2. How OFTEN does chkdsk run on startup? (I was under the impression it was EVERY TIME BUT after moving the Default User Folders, I shut down and started up my computer for two to three days before it made the changes. Once, it did it on the same day, just after I moved the folders.)
    3. As an alternative, AFTER I re-enable (actually re-"Add") the "Users" and "Authenticated Users" Security Profiles ("SYSTEM" and "Administrators" do NOT disappear)...How can I get to the data, files and folders on the drive? (Remember it shows data but double-clicking the drive shows "This folder is empty")
    12-29-2019 09:45 PM
  2. Ryujingt3's Avatar
    Firstly, checkdisk should never run always on startup. If it's doing that then something is definitely wrong with your drive and its files/folder layout.

    Does this help you if you use it to disable chkdsk?

    https://mywindowshub.com/cancel-sche...ot-windows-10/
    Laura Knotek likes this.
    12-30-2019 10:56 PM
  3. oxfordia's Avatar
    I'm of a different opinion now.
    Today I started up and "skipped" "disk check".
    Today I have a message: "D:\D User\Desktop is not accessible. The parameter is incorrect."
    Next, upon "trying" to explore "This Computer" I get "D:\D User\Desktop is not accessible. The disk structure is corrupted and unreadable."
    D: drive is preent, but not even greyed out.
    So...skipping disk check will not work.
    I have and (older, smaller) SSD as C: drive (for OS and programs)and two HDDs installed (one for moved "Desktop" with a folder named "D User" for Documents, Downloads, Pictures, Videos (which I'm trying above mentioned method..see link) and other files and folders stored on D: drive and an E: drive for backups of C: drive and E: drive)"
    Interestingly, clicking on my User shortcut on the desktop brings up another error: "These files can't be opened. Your internet security settings prevented one or more files from being opened. (D:\D User\Desktop).
    Another thing I've recently noticed is that one or more of my HDDs starts up (I can hear an audible whirring, winding up, starting noise) occasionally. Probably when accessing it, writing to it, and/or upon startup. Perhaps it doesn't start up fast enough for the SSD.
    Maybe changing the BIOS to access D: drive before C: drive?
    It's a new build. Trying a new method.
    Perhaps I need to go back to doing things normally rather than playing around with moving Desktop.
    12-31-2019 02:04 PM
  4. oxfordia's Avatar
    Wow, quite a few grammatical errors above....>
    E: drive for backups of C: and D: drives.
    12-31-2019 05:47 PM
  5. Ryujingt3's Avatar
    Are you sure the partitions or drives you have moved the default folders too are actually healthy to start with? If you boot off an SSD but the default folders are located on hard drives then it definitely is possible that the hard drive's slower boot times and access speeds, compared to the SSD, could also be contributing to this. Exactly as you have described.
    12-31-2019 06:25 PM
  6. oxfordia's Avatar
    HDD "IS" healthy.
    Did CHKDSK and no issues.
    Did "reformat" of D: drive at least once before restoring image.
    Also tried starting fresh, by moving the Desktop and four folders.
    Maybe I shouldn't be moving the Desktop (folder) to the D: drive.
    Maybe I'll try NOT moving the "Desktop" (folder) and only move "Documents, Downloads, Pictures, and Videos" folders.
    12-31-2019 06:54 PM
  7. Ryujingt3's Avatar
    HDD "IS" healthy.
    Did CHKDSK and no issues.
    Did "reformat" of D: drive at least once before restoring image.
    Also tried starting fresh, by moving the Desktop and four folders.
    Maybe I shouldn't be moving the Desktop (folder) to the D: drive.
    Maybe I'll try NOT moving the "Desktop" (folder) and only move "Documents, Downloads, Pictures, and Videos" folders.
    What's stopping you from installing Windows as normal, then, within Windows, just right click each folder (Documents, Downloads, Pictures, Videos etc.) and then go to the Location tab > Move > then select the external drive to move it to and then go from there?
    01-02-2020 04:46 AM
  8. oxfordia's Avatar
    Alright,
    Started over WITHOUT moving "Desktop" folder (Caused issues trying to move it back to C:\Users\~ folder).
    I just moved ONLY the four folders I use the most (using your method, which is same method as original blog method).
    [I figured since I usually store Temp documents and folders on the Desktop, I should move the Desktop Folder too]
    TOO MANY ISSUES with THAT.
    We'll see how it goes.
    I "Imagine" "Problem Solved".
    01-03-2020 01:30 AM
  9. Ryujingt3's Avatar
    Alright,
    Started over WITHOUT moving "Desktop" folder (Caused issues trying to move it back to C:\Users\~ folder).
    I just moved ONLY the four folders I use the most (using your method, which is same method as original blog method).
    [I figured since I usually store Temp documents and folders on the Desktop, I should move the Desktop Folder too]
    TOO MANY ISSUES with THAT.
    We'll see how it goes.
    I "Imagine" "Problem Solved".
    Out of interest, why not just change the folder locations within Windows like I mentioned above? It's most likely much safer and linking to them any other way, as you have tried, is most likely not what Windows 10 is designed to do, hence your issues.
    01-05-2020 03:20 AM
  10. oxfordia's Avatar
    Yes, your suggestion is basically the WindowsCentral article (less the %homepath% step).
    I used your suggestion of just browsing to the folder, clicking the "Location" tab and "Move" function.
    What I didn't do was "Move" the "Desktop" folder location.
    All "seems" well so far (two days).
    01-05-2020 10:33 AM
  11. oxfordia's Avatar
    Well, chkdsk again today.
    Reading there is a "dirty bit" that causes this.
    Used EaseUS Data Recovery to scan and recover files.
    (NOT necessary but messing around, trying things out for future crashes)
    (It works...so well that it recovered or at least read a lot of fragments from old OS/files)
    Used "WipeDrive Pro" to write zeros to each bit.
    (I usually don't install drives without wiping them first - NO bad sectors found)
    Didn't need to format drive (which seemed odd)
    Tried initializing it GPT (was MBR)
    Drive was "locked" (write-protected...another oddity)
    Went into DOS to clear read-only attributes and clean.
    Then initialized it GPT in Disk Manager.
    Then formatted in DOS.
    Hoping this works.
    01-07-2020 03:06 AM
  12. Ryujingt3's Avatar
    Well, chkdsk again today.
    Reading there is a "dirty bit" that causes this.
    Used EaseUS Data Recovery to scan and recover files.
    (NOT necessary but messing around, trying things out for future crashes)
    (It works...so well that it recovered or at least read a lot of fragments from old OS/files)
    Used "WipeDrive Pro" to write zeros to each bit.
    (I usually don't install drives without wiping them first - NO bad sectors found)
    Didn't need to format drive (which seemed odd)
    Tried initializing it GPT (was MBR)
    Drive was "locked" (write-protected...another oddity)
    Went into DOS to clear read-only attributes and clean.
    Then initialized it GPT in Disk Manager.
    Then formatted in DOS.
    Hoping this works.
    That definitely sounds like a lot of work, but good luck and let us know how you get on.
    01-07-2020 07:43 AM

Similar Threads

  1. Surface Go Tablet will not recognize my SD Card
    By Tegiro in forum Windows 10
    Replies: 3
    Last Post: 01-22-2020, 01:34 AM
  2. Add storage to your setup with $27 off the 10TB WD Elements hard drive
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-30-2019, 09:30 AM
  3. Not interested in Edge Chromium? Here's how to stop the automatic install.
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-27-2019, 06:11 AM
  4. Surface Go Tablet will not recognize my SD Card
    By Tegiro in forum Ask a Question
    Replies: 1
    Last Post: 12-26-2019, 06:37 PM
  5. Review: The ThinkPad X1 Extreme is better than ever after a 2019 refresh
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-23-2019, 08:11 AM
LINK TO POST COPIED TO CLIPBOARD