1. swy81's Avatar
    Hi, I just received my T100TAM yesterday. Unit looks good but the resolution is something I'll have to adjust to (coming from a Miix 2 10). Had a couple of questions/concerns regarding this machine.

    1) The power button seems "mushy"? Meaning there is no noticeable click when powering on the machine. It just pushes in.
    2) This one is a little more concerning but, this is a brand new machine. When I took it out of the box for the first time and tried to turn it on, it was completely dead. I had to fully charge the unit. I thought new machines came with a charge? Don't know if this means there may be issues with the battery holding a charge.
    3) The trackpad 2 finger scroll seems to have a delay. If I scroll with 2 fingers, the trackpad will register it about a split second later. There is a noticeable delay. Is there anyway to adjust this?
    4) There is noticeable light bleed around all 4 sides of the screen. Especially when it's black and the unit is booting up. When it's actually in Windows, I don't really seem to notice it. Is this normal?

    Sorry for all of the questions. I guess as a new owner, I want to make sure my unit is as perfect as can be.
    01-14-2015 09:07 AM

Similar Threads

  1. Lumia 620 With Nokia XPress 5800 Battery will work ?
    By AndroidJelly in forum Windows Phone 8.1
    Replies: 11
    Last Post: 01-15-2015, 07:06 PM
  2. new 930 owner
    By Vicki Barber in forum New to the Forums? Introduce Yourself Here!
    Replies: 10
    Last Post: 01-15-2015, 03:39 PM
  3. 1) Tell the release date of lumia 1525. will it support 4G ?
    By Windows Central Question in forum Ask a Question
    Replies: 5
    Last Post: 01-14-2015, 08:02 PM
  4. What ROM work best with the Lumia 1520 RM-937?
    By ibamba in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 01-14-2015, 06:32 PM
  5. Replies: 0
    Last Post: 01-14-2015, 08:37 AM
LINK TO POST COPIED TO CLIPBOARD